summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-08-03 21:01:18 -0400
committerMark H Weaver <mhw@netris.org>2014-08-03 21:01:18 -0400
commit8ceaf72c6d50e564d6db49479e9facbb2201c3e3 (patch)
treee558765dcfcb1c954b68f200760180d199926803 /gnu
parent33690ffde5af2c516bc6b2dd060ab9cf7ab88eb2 (diff)
parent684a2f59748d55de62b45c190127b704d4cdcb60 (diff)
downloadguix-patches-8ceaf72c6d50e564d6db49479e9facbb2201c3e3.tar
guix-patches-8ceaf72c6d50e564d6db49479e9facbb2201c3e3.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gcc.scm11
-rw-r--r--gnu/packages/gdb.scm15
-rw-r--r--gnu/packages/linux.scm4
3 files changed, 21 insertions, 9 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index aed2e8925e..938c38e670 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -281,10 +281,13 @@ Go. It also includes runtime support libraries for these languages.")
(base32
"0zki3ngi0gsidnmsp88mjl2868cc7cm5wm1vwqw6znja28d7hd6k"))))))
-(define (custom-gcc gcc name languages)
+(define* (custom-gcc gcc name languages #:key (separate-lib-output? #t))
"Return a custom version of GCC that supports LANGUAGES."
(package (inherit gcc)
(name name)
+ (outputs (if separate-lib-output?
+ (package-outputs gcc)
+ (delete "lib" (package-outputs gcc))))
(arguments
(substitute-keyword-arguments `(#:modules ((guix build gnu-build-system)
(guix build utils)
@@ -302,7 +305,11 @@ Go. It also includes runtime support libraries for these languages.")
(custom-gcc gcc-4.8 "gfortran" '("fortran")))
(define-public gccgo-4.8
- (custom-gcc gcc-4.8 "gccgo" '("go")))
+ (custom-gcc gcc-4.8 "gccgo" '("go")
+ ;; Suppress the separate "lib" output, because otherwise the
+ ;; "lib" and "out" outputs would refer to each other, creating
+ ;; a cyclic dependency. <http://debbugs.gnu.org/18101>
+ #:separate-lib-output? #f))
(define-public gcc-objc-4.8
(custom-gcc gcc-4.8 "gcc-objc" '("objc")))
diff --git a/gnu/packages/gdb.scm b/gnu/packages/gdb.scm
index 1b8a0bbe22..b8d622e89d 100644
--- a/gnu/packages/gdb.scm
+++ b/gnu/packages/gdb.scm
@@ -24,7 +24,9 @@
#:use-module (gnu packages texinfo)
#:use-module (gnu packages multiprecision)
#:use-module (gnu packages xml)
+ #:use-module (gnu packages guile)
#:use-module (gnu packages python)
+ #:use-module (gnu packages pkg-config)
#:use-module ((guix licenses) #:select (gpl3+))
#:use-module (guix packages)
#:use-module (guix download)
@@ -33,14 +35,14 @@
(define-public gdb
(package
(name "gdb")
- (version "7.7.1")
+ (version "7.8")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/gdb/gdb-"
- version ".tar.bz2"))
+ version ".tar.xz"))
(sha256
(base32
- "199sn1p0gzli6icp9dcvrphdvyi7hm4cc9zhziq0q6vg81h55g8d"))))
+ "0xdqxjj77q60k19hn85msnbv9nchnpzi0lp7z7hm97zpfkhspi29"))))
(build-system gnu-build-system)
(arguments
'(#:tests? #f ; FIXME "make check" fails on single-processor systems.
@@ -56,14 +58,17 @@
("gmp" ,gmp)
("readline" ,readline)
("ncurses" ,ncurses)
- ("python" ,python-wrapper)
+ ("guile" ,guile-2.0)
+ ("python" ,python)
+ ("python-wrapper" ,python-wrapper)
("dejagnu" ,dejagnu)
;; Allow use of XML-formatted syscall information. This enables 'catch
;; syscall' and similar commands.
("libxml2" ,libxml2)))
(native-inputs
- `(("texinfo" ,texinfo)))
+ `(("texinfo" ,texinfo)
+ ("pkg-config" ,pkg-config)))
(home-page "http://www.gnu.org/software/gdb/")
(synopsis "The GNU debugger")
(description
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 3ffe2a4cdd..105a8cb5c6 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -186,7 +186,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
#f)))
(define-public linux-libre
- (let* ((version "3.15.6")
+ (let* ((version "3.15.8")
(build-phase
'(lambda* (#:key system inputs #:allow-other-keys #:rest args)
;; Apply the neat patch.
@@ -259,7 +259,7 @@ for SYSTEM, or #f if there is no configuration for SYSTEM."
(uri (linux-libre-urls version))
(sha256
(base32
- "07v45q8r9fz9jgj1m7dibbmcdlzfzpcj7kh2bp1s1pv512h7fnw0"))))
+ "1ichq7b08rrfq61i8kpan9vxw9mxcfpcl8cw0a6lbc1ycwzvm7xw"))))
(build-system gnu-build-system)
(native-inputs `(("perl" ,perl)
("bc" ,bc)