summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-11-10 22:44:57 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-11-10 23:29:26 +0100
commitb255365cd162920ff51c62f319370283218bfcb3 (patch)
tree30852af52e9d05f17a6d02c9de4330e2fb94af0e /gnu
parent78eff857708b527adfaa9d5964e4a73aaf7854bd (diff)
downloadguix-patches-b255365cd162920ff51c62f319370283218bfcb3.tar
guix-patches-b255365cd162920ff51c62f319370283218bfcb3.tar.gz
gnu: lvtk: Fetch sources from git.
* gnu/packages/audio.scm (lvtk)[source]: Fetch from git.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index ee18b00226..5e02291502 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1879,14 +1879,14 @@ software.")
(name "lvtk")
(version "1.2.0")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/lvtk/lvtk/archive/"
- version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lvtk/lvtk.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "03nbj2cqcklqwh50zj2gwm07crh5iwqbpxbpzwbg5hvgl4k4rnjd"))))
+ "1b01zvzl70ana6l1kn8fgyr7msnn3c7x61cgw7fdpp50322352p8"))))
(build-system waf-build-system)
(arguments
`(#:tests? #f ; no check target