summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:22:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:21 +0200
commitf8c88560db1d3436f9a27d1720d6af8b6333fdaf (patch)
treeabc25f814847b232a229c7086b25432e18ca2b70 /gnu
parent2f00425b4e07a0492b70cec0911a8644fe6f9489 (diff)
downloadguix-patches-f8c88560db1d3436f9a27d1720d6af8b6333fdaf.tar
guix-patches-f8c88560db1d3436f9a27d1720d6af8b6333fdaf.tar.gz
gnu: Add r-rfigshare.
* gnu/packages/cran.scm (r-rfigshare): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 23076e77cb..e99c959639 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30503,3 +30503,31 @@ Standards.")
"This package combines a forecast of a time series, using the function @code{forecast},
with the dynamic plots from @code{dygraphs}.")
(license license:gpl2+)))
+
+(define-public r-rfigshare
+ (package
+ (name "r-rfigshare")
+ (version "0.3.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "rfigshare" version))
+ (sha256
+ (base32
+ "1qgzn0mpjy4czy0pnbi395fxxx84arkg8r7rk8aidmd34584gjiq"))))
+ (properties `((upstream-name . "rfigshare")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ggplot2" ,r-ggplot2)
+ ("r-httpuv" ,r-httpuv)
+ ("r-httr" ,r-httr)
+ ("r-plyr" ,r-plyr)
+ ("r-rjsonio" ,r-rjsonio)
+ ("r-xml" ,r-xml)
+ ("r-yaml" ,r-yaml)))
+ (home-page "https://github.com/ropensci/rfigshare")
+ (synopsis "R Interface to figshare")
+ (description
+ "This package provides an interface to figshare, a scientific repository
+to archive and assign DOIs to data, software, figures, and more.")
+ (license license:cc0)))