summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-07 22:24:53 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-07 22:24:53 +0100
commitae2aa18dba62afbe911fb0f6b7ffdd52fa1b5d26 (patch)
treed7ae29f4fa6edb8f094543f09c2ad2467c7ebb68 /gnu
parent8ec0d3fbcf6a5bb16a72a5b95b38ed03aaeda604 (diff)
downloadguix-patches-ae2aa18dba62afbe911fb0f6b7ffdd52fa1b5d26.tar
guix-patches-ae2aa18dba62afbe911fb0f6b7ffdd52fa1b5d26.tar.gz
gnu: Add perl-http-date.
* gnu/packages/web.scm (perl-http-date): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 49376ceddd..e18d49e99e 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -109,3 +109,23 @@ it from plain text (alias data content) in HTML documents. As different
kinds of markup and text are recognized, the corresponding event handlers
are invoked.")
(home-page "http://search.cpan.org/~gaas/HTML-Parser/")))
+
+(define-public perl-http-date
+ (package
+ (name "perl-http-date")
+ (version "6.02")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/G/GA/GAAS/HTTP-Date-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0cz357kafhhzw7w59iyi0wvhw7rlh5g1lh38230ckw7rl0fr9fg8"))))
+ (build-system perl-build-system)
+ (license (package-license perl))
+ (synopsis "Perl date conversion routines")
+ (description
+ "The HTTP::Date module provides functions that deal with date formats
+used by the HTTP protocol (and then some more).")
+ (home-page "http://search.cpan.org/~gaas/HTTP-Date/")))