summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-07 22:05:59 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-07 22:20:53 +0100
commit8ec0d3fbcf6a5bb16a72a5b95b38ed03aaeda604 (patch)
tree41cd07f44d6970697e508d6b218bf56b57eb8f8c /gnu
parentc9ea41ffd24bcfe54cc7788a4a07b2533b602357 (diff)
downloadguix-patches-8ec0d3fbcf6a5bb16a72a5b95b38ed03aaeda604.tar
guix-patches-8ec0d3fbcf6a5bb16a72a5b95b38ed03aaeda604.tar.gz
gnu: Add perl-html-parser.
* gnu/packages/web.scm (perl-html-parser): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 9f143b4270..49376ceddd 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -86,3 +86,26 @@ related documentation.")
kinds of HTML parsing operations.")
(home-page "http://search.cpan.org/dist/HTML-Tagset/")))
+(define-public perl-html-parser
+ (package
+ (name "perl-html-parser")
+ (version "3.71")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/G/GA/GAAS/HTML-Parser-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "00nqzdgl7c3jilx7mil19k5jwcw3as14pvkjgxi97zyk94vqp4dy"))))
+ (build-system perl-build-system)
+ (inputs
+ `(("perl-html-tagset" ,perl-html-tagset)))
+ (license (package-license perl))
+ (synopsis "Perl HTML parser class")
+ (description
+ "Objects of the HTML::Parser class will recognize markup and separate
+it from plain text (alias data content) in HTML documents. As different
+kinds of markup and text are recognized, the corresponding event handlers
+are invoked.")
+ (home-page "http://search.cpan.org/~gaas/HTML-Parser/")))