summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2021-07-08 17:07:42 +0200
committerMathieu Othacehe <othacehe@gnu.org>2021-07-08 21:19:32 +0200
commit3cd509bf66dc322d89dfcf8e1608b53b859206a0 (patch)
tree297a3a5226e136f6e26d63530673d6f89f9f5eb8 /gnu
parentbeaa5dff38db8c31a99d7f4484864b12c838b4e2 (diff)
downloadguix-patches-3cd509bf66dc322d89dfcf8e1608b53b859206a0.tar
guix-patches-3cd509bf66dc322d89dfcf8e1608b53b859206a0.tar.gz
gnu: python-pymediainfo: Respect "--without-tests".
* gnu/packages/python-xyz.scm (python-pymediainfo)[arguments]<#:phases>{check}: Respect #:tests?. Don't bother returning #t as it isn't required anymore. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index cca4d9a830..5a44043635 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -103,6 +103,7 @@
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 jgart <jgart@dismail.de>
;;; Copyright © 2021 Danial Behzadi <dani.behzi@ubuntu.com>
+;;; Copyright © 2021 Maxime Devos <maximedevos@telenet.be>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -857,14 +858,14 @@ to CommonMark.")
"/lib/libmediainfo.so.0")))
#t))
(replace 'check
- (lambda _
- ;; Extend PYTHONPATH so the built package will be found.
- (setenv "PYTHONPATH"
- (string-append (getcwd) "/build/lib:"
- (getenv "PYTHONPATH")))
- ;; Skip the only failing test "test_parse_url"
- (invoke "pytest" "-vv" "-k" "not test_parse_url")
- #t)))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Extend PYTHONPATH so the built package will be found.
+ (setenv "PYTHONPATH"
+ (string-append (getcwd) "/build/lib:"
+ (getenv "PYTHONPATH")))
+ ;; Skip the only failing test "test_parse_url"
+ (invoke "pytest" "-vv" "-k" "not test_parse_url")))))))
(home-page
"https://github.com/sbraz/pymediainfo")
(synopsis