summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 11:22:42 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:21 +0200
commit26cc1eafe77d4f033a498705ffdaf3aea3f6fc10 (patch)
tree660dee3a557f3246d94d9e5cb8baa678dea1365f /gnu
parent8b00e7055825b8c4902d7b839a94cea680722c6c (diff)
downloadguix-patches-26cc1eafe77d4f033a498705ffdaf3aea3f6fc10.tar
guix-patches-26cc1eafe77d4f033a498705ffdaf3aea3f6fc10.tar.gz
gnu: Add r-zoon.
* gnu/packages/cran.scm (r-zoon): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4a54183af4..eb00a6f3fb 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30557,3 +30557,38 @@ to archive and assign DOIs to data, software, figures, and more.")
predicting the environmental similarity of any site to that of the locations
of known occurrences of a species.")
(license license:gpl3+)))
+
+(define-public r-zoon
+ (package
+ (name "r-zoon")
+ (version "0.6.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "zoon" version))
+ (sha256
+ (base32
+ "02y29vr2yn8al69km8faiqrwjrc1r3hsvw3dg8lwjr65cxw1krip"))))
+ (properties `((upstream-name . "zoon")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-dismo" ,r-dismo)
+ ("r-plyr" ,r-plyr)
+ ("r-randomforest" ,r-randomforest)
+ ("r-raster" ,r-raster)
+ ("r-rcurl" ,r-rcurl)
+ ("r-rfigshare" ,r-rfigshare)
+ ("r-rgdal" ,r-rgdal)
+ ("r-roxygen2" ,r-roxygen2)
+ ("r-rworldmap" ,r-rworldmap)
+ ("r-sp" ,r-sp)
+ ("r-testthat" ,r-testthat)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://github.com/zoonproject/zoon")
+ (synopsis "Reproducible, accessible and shareable species distribution modelling")
+ (description
+ "This package reads user submitted modules from an online repository,
+runs full species distribution modelling workflows and returns output that is
+fully reproducible.")
+ (license license:bsd-3)))