summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:15:53 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:32 +0200
commitb2bc1daf98251250b21b35e9cda902372535fe6b (patch)
treeb413485b4aed5137fa796bf2dce635a33154ce85 /gnu
parent3921bc7c246d558aec66f691dde5948e8a42fbe2 (diff)
downloadguix-patches-b2bc1daf98251250b21b35e9cda902372535fe6b.tar
guix-patches-b2bc1daf98251250b21b35e9cda902372535fe6b.tar.gz
gnu: Add texlive-latex-listings.
* gnu/packages/tex.scm (texlive-latex-listings): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 625761009d..5e417bf986 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -1925,6 +1925,29 @@ the same place. The package also has a range of techniques for labelling
footnotes with symbols rather than numbers.")
(license license:lppl1.3+)))
+(define-public texlive-latex-listings
+ (package
+ (name "texlive-latex-listings")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (texlive-ref "latex" "listings"))
+ (sha256
+ (base32
+ "1nsn9wp3wl12b36c0sqrim33lf33cr5wky0h4ncnw8lvqgm7h8wf"))))
+ (build-system texlive-build-system)
+ (arguments
+ '(#:tex-directory "latex/listings"
+ #:build-targets '("listings.ins")))
+ (home-page "http://www.ctan.org/pkg/listings")
+ (synopsis "Typeset source code listings using LaTeX")
+ (description
+ "The package enables the user to typeset programs (programming code)
+within LaTeX; the source code is read directly by TeX---no front-end processor
+is needed. Keywords, comments and strings can be typeset using different
+styles. Support for @code{hyperref} is provided.")
+ (license license:lppl1.3+)))
+
(define texlive-texmf
(package
(name "texlive-texmf")