summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-07-02 15:18:20 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-07-09 17:07:34 +0200
commitacc620d6ed608cd80ae4c3d7ca749af1e0a1ce46 (patch)
treeb56ea6bd378e4364150ff1945f7bf79f7d98bd8f /gnu
parent2db3a03445aed196ffdcd0a92fe642b4e72d8745 (diff)
downloadguix-patches-acc620d6ed608cd80ae4c3d7ca749af1e0a1ce46.tar
guix-patches-acc620d6ed608cd80ae4c3d7ca749af1e0a1ce46.tar.gz
gnu: Add texlive-latex-titlesec.
* gnu/packages/tex.scm (texlive-latex-titlesec): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 5baca164ec..50966b9a59 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2122,6 +2122,41 @@ considered obsolete: it was superseded by @code{subfig}, but users may find
the more recent @code{subcaption} package more satisfactory.")
(license license:lppl)))
+(define-public texlive-latex-titlesec
+ (package
+ (name "texlive-latex-titlesec")
+ (version (number->string %texlive-revision))
+ (source (origin
+ (method svn-fetch)
+ (uri (svn-reference
+ (url (string-append "svn://www.tug.org/texlive/tags/"
+ %texlive-tag "/Master/texmf-dist/"
+ "/tex/latex/titlesec"))
+ (revision %texlive-revision)))
+ (sha256
+ (base32
+ "04nmkhqx6jxcxx9a30zbcd5smxi5fd0cbp132bki7fnvhspnhg21"))))
+ (build-system trivial-build-system)
+ (arguments
+ `(#:modules ((guix build utils))
+ #:builder
+ (begin
+ (use-modules (guix build utils))
+ (let ((target (string-append (assoc-ref %outputs "out")
+ "/share/texmf-dist/tex/latex/titlesec")))
+ (mkdir-p target)
+ (copy-recursively (assoc-ref %build-inputs "source") target)
+ #t))))
+ (home-page "http://www.ctan.org/pkg/titlesec")
+ (synopsis "Select alternative section titles")
+ (description
+ "This package provides an interface to sectioning commands for selection
+from various title styles, e.g. for marginal titles and to change the font of
+all headings with a single command, also providing simple one-step page
+styles. It also includes a package to change the page styles when there are
+floats in a page. You may assign headers/footers to individual floats, too.")
+ (license license:lppl)))
+
(define texlive-texmf
(package
(name "texlive-texmf")