summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTimotej Lazar <timotej.lazar@araneo.si>2020-07-15 19:13:47 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2020-07-17 01:51:56 +0200
commit0fc715f9712424b0147c6bd261ce10c25fe73082 (patch)
treecc41ac831f9aa93a2b1087ca7f31b47eb91ac7e1 /gnu
parentba7a63da4822d53298d64a31e3dd55bc60bad62a (diff)
downloadguix-patches-0fc715f9712424b0147c6bd261ce10c25fe73082.tar
guix-patches-0fc715f9712424b0147c6bd261ce10c25fe73082.tar.gz
gnu: hedgewars: Install desktop icon.
* gnu/packages/games.scm (hedgewars)[arguments]: Add ‘install-icon’ phase. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 5de6dbf4ac..e60c455cb6 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -8813,7 +8813,15 @@ play with up to four players simultaneously. It has network support.")
#:phases
(modify-phases %standard-phases
(replace 'check
- (lambda _ (invoke "ctest"))))))
+ (lambda _ (invoke "ctest")))
+ (add-after 'install 'install-icon
+ (lambda _
+ ;; Install icon for the desktop file.
+ (let* ((out (assoc-ref %outputs "out"))
+ (icons (string-append out "/share/icons/hicolor/512x512/apps")))
+ (with-directory-excursion (string-append "../hedgewars-src-" ,version)
+ (install-file "misc/hedgewars.png" icons)))
+ #t)))))
(inputs
`(("ffmpeg" ,ffmpeg)
("freeglut" ,freeglut)