summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-06 21:13:38 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-06 21:13:38 +0100
commitbfb93b4889a2352f47df56dedf0a10cd2dfc441c (patch)
tree921260f4aae14f007a1b78d37eac770a9f14cc9d /gnu
parent9f8698ad1c9c80ddff4ec66eef3d262db5212299 (diff)
downloadguix-patches-bfb93b4889a2352f47df56dedf0a10cd2dfc441c.tar
guix-patches-bfb93b4889a2352f47df56dedf0a10cd2dfc441c.tar.gz
gnu: r-geneplotter: Move to (gnu packages bioconductor).
* gnu/packages/bioinformatics.scm (r-geneplotter): Move from here... * gnu/packages/bioconductor.scm (r-geneplotter): ...to here.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm27
-rw-r--r--gnu/packages/bioinformatics.scm25
2 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index bbfe68c5cc..f3ea87cdb1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016, 2017, 2018, 2019 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2016, 2017, 2018 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -349,6 +349,31 @@ customizable permutation tests to assess the association between genomic
region sets and other genomic features.")
(license license:artistic2.0)))
+(define-public r-geneplotter
+ (package
+ (name "r-geneplotter")
+ (version "1.60.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "geneplotter" version))
+ (sha256
+ (base32
+ "10khr0pznxf3m0f5gzck9ymljrwcv3vamfmpskd51yjh36lhllqz"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-annotate" ,r-annotate)
+ ("r-annotationdbi" ,r-annotationdbi)
+ ("r-biobase" ,r-biobase)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-lattice" ,r-lattice)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)))
+ (home-page "https://bioconductor.org/packages/geneplotter")
+ (synopsis "Graphics functions for genomic data")
+ (description
+ "This package provides functions for plotting genomic data.")
+ (license license:artistic2.0)))
+
(define-public r-diffbind
(package
(name "r-diffbind")
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 09d3bf2090..73d6ecf135 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6347,31 +6347,6 @@ between two different types of motif instances using as much relevant
information as possible.")
(license (list license:gpl2+ license:gpl3+))))
-(define-public r-geneplotter
- (package
- (name "r-geneplotter")
- (version "1.60.0")
- (source
- (origin
- (method url-fetch)
- (uri (bioconductor-uri "geneplotter" version))
- (sha256
- (base32
- "10khr0pznxf3m0f5gzck9ymljrwcv3vamfmpskd51yjh36lhllqz"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-annotate" ,r-annotate)
- ("r-annotationdbi" ,r-annotationdbi)
- ("r-biobase" ,r-biobase)
- ("r-biocgenerics" ,r-biocgenerics)
- ("r-lattice" ,r-lattice)
- ("r-rcolorbrewer" ,r-rcolorbrewer)))
- (home-page "https://bioconductor.org/packages/geneplotter")
- (synopsis "Graphics functions for genomic data")
- (description
- "This package provides functions for plotting genomic data.")
- (license license:artistic2.0)))
-
(define-public r-genefilter
(package
(name "r-genefilter")