summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-02-10 22:02:24 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-25 11:56:31 +0100
commit4f77ba17c663881c0657c838fbcb2a98e9137aa5 (patch)
tree3136e09fea41d0bd318e7e193e87a5f772f97340 /gnu
parenta7ad92ade94d456f991062aedede9fd1ecd64b07 (diff)
downloadguix-patches-4f77ba17c663881c0657c838fbcb2a98e9137aa5.tar
guix-patches-4f77ba17c663881c0657c838fbcb2a98e9137aa5.tar.gz
gnu: Add java-plexus-cipher.
* gnu/packages/java.scm (java-plexus-cipher): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 7312d4703d..57370db76e 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2674,6 +2674,42 @@ archives (jar).")
(description "This package is a Maven plugin to generate Plexus descriptors
from source tags and class annotations.")))
+(define-public java-plexus-cipher
+ (package
+ (name "java-plexus-cipher")
+ (version "1.7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/codehaus-plexus/plexus-cipher"
+ "/archive/plexus-cipher-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1j3r8xzlxlk340snkjp6lk2ilkxlkn8qavsfiq01f43xmvv8ymk3"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "plexus-cipher.jar"
+ #:source-dir "src/main/java"
+ #:jdk ,icedtea-8
+ #:tests? #f; FIXME: requires sisu-inject-bean
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'copy-resources
+ (lambda _
+ (copy-recursively "src/main/resources" "build/classes")
+ (mkdir-p "build/classes/META-INF/sisu")
+ (with-output-to-file "build/classes/META-INF/sisu/javax.inject.Named"
+ (lambda _
+ (display "org.sonatype.plexus.components.cipher.DefaultPlexusCipher\n")))
+ #t)))))
+ (inputs
+ `(("java-cdi-api" ,java-cdi-api)
+ ("java-javax-inject" ,java-javax-inject)))
+ (home-page "https://github.com/sonatype/plexus-cipher")
+ (synopsis "Encryption/decryption Component")
+ (description "Plexus-cipher contains a component to deal with encryption
+and decryption.")
+ (license license:asl2.0)))
+
(define-public java-asm
(package
(name "java-asm")