summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2018-05-30 23:47:20 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2018-06-12 22:47:01 +0200
commitb5792b9cb8c592d4b6da76bbb2acb55cd233e715 (patch)
tree281517bf8968f91f5747ce9c28bccb8e9b6e3efe /gnu
parent359e30c9ea8985738c3dc1057438abb7215d608b (diff)
downloadguix-patches-b5792b9cb8c592d4b6da76bbb2acb55cd233e715.tar
guix-patches-b5792b9cb8c592d4b6da76bbb2acb55cd233e715.tar.gz
gnu: Add qtwebglplugin.
* gnu/packages/qt.scm (qtwebglplugin): New variable. Co-authored-by: 宋文武 <iyzsong@member.fsf.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/qt.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 107b5dff49..a15d6453c9 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1070,6 +1070,32 @@ between the host (QML/C++ application) and the client (HTML/JavaScript
application). The transport mechanism is supported out of the box by the two
popular web engines, Qt WebKit 2 and Qt WebEngine.")))
+(define-public qtwebglplugin
+ (package (inherit qtsvg)
+ (name "qtwebglplugin")
+ (version "5.11.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://download.qt.io/official_releases/qt/"
+ (version-major+minor version) "/" version
+ "/submodules/" name "-everywhere-src-"
+ version ".tar.xz"))
+ (sha256
+ (base32
+ "1al7dv7i9rg4z4p8vnipbjbbgc6113lbfjggxxap3sn6hqs986fm"))))
+ (native-inputs '())
+ (inputs
+ `(("mesa" ,mesa)
+ ("qtbase" ,qtbase)
+ ("qtwebsockets" ,qtwebsockets)))
+ (synopsis "QPA plugin for running an application via a browser using
+streamed WebGL commands")
+ (description "Qt back end that uses WebGL for rendering. It allows Qt
+applications (with some limitations) to run in a web browser that supports
+WebGL. WebGL is a JavaScript API for rendering 2D and 3D graphics within any
+compatible web browser without the use of plug-ins. The API is similar to
+OpenGL ES 2.0 and can be used in HTML5 canvas elements")))
+
(define-public qtwebview
(package (inherit qtsvg)
(name "qtwebview")