summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-22 00:29:35 -0500
committerLeo Famulari <leo@famulari.name>2016-02-28 22:06:24 -0500
commit823e2ed4b39547608438f91d1a594772890a7f27 (patch)
tree17aae9644c65d2699a4c74afdef8bbb1602169a4 /gnu
parent1a59b6d01423060f6364596376db96984b3dccf1 (diff)
downloadguix-patches-823e2ed4b39547608438f91d1a594772890a7f27.tar
guix-patches-823e2ed4b39547608438f91d1a594772890a7f27.tar.gz
gnu: msmtp: Install msmtpq.
* gnu/packages/mail.scm (msmtp)[arguments]: Install msmtpq scripts.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/mail.scm15
1 files changed, 14 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 5a9f420b43..e4fc65f581 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -11,6 +11,7 @@
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Al McElrath <hello@yrns.org>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -629,7 +630,19 @@ which can add many functionalities to the base client.")
(arguments
`(#:configure-flags (list "--with-libgsasl"
"--with-libidn"
- "--with-tls=gnutls")))
+ "--with-tls=gnutls")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-msmtpq
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin"))
+ (doc (string-append out "/share/doc/msmtp"))
+ (msmtpq (string-append "scripts/msmtpq")))
+ (install-file (string-append msmtpq "/msmtpq") bin)
+ (install-file (string-append msmtpq "/msmtp-queue") bin)
+ (install-file (string-append msmtpq "/README.msmtpq") doc)
+ #t))))))
(synopsis
"Simple and easy to use SMTP client with decent sendmail compatibility")
(description