summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-06-23 23:53:39 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-06-25 08:54:39 +0200
commitf27b9659341853198d15d6eba0d492a3e8e5773b (patch)
tree71fafb92b8145f69a7f54b42fcaa32b68ef69461 /gnu
parent6c83c7980fd95f504ca8955b651eeb4bfa78768a (diff)
downloadguix-patches-f27b9659341853198d15d6eba0d492a3e8e5773b.tar
guix-patches-f27b9659341853198d15d6eba0d492a3e8e5773b.tar.gz
gnu: Add emacs-make-it-so.
* gnu/packages/emacs-xyz.scm (emacs-make-it-so): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0ba806ef22..fb97f666fb 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -8820,6 +8820,36 @@ well as Github-style emojis like @code{:smile:}. It provides a minor mode
@code{emojify-mode} to enable the display of emojis in a buffer.")
(license license:gpl3+)))
+(define-public emacs-make-it-so
+ (let ((commit "bc3b01d6b9ed6ff66ebbd524234f9d6df60dd4be")
+ (version "0.1.0")
+ (revision "1"))
+ (package
+ (name "emacs-make-it-so")
+ (version (git-version version revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abo-abo/make-it-so")
+ (commit commit)))
+ (sha256
+ (base32
+ "0833bzlscpnkvjnrg3g54yr246afbjwri8n5wxk8drnsq6acvd8z"))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:include (cons "^recipes/" %default-include)))
+ (propagated-inputs
+ `(("emacs-ivy" ,emacs-ivy)))
+ (home-page "https://github.com/abo-abo/make-it-so")
+ (synopsis "Transform files with Makefile recipes")
+ (description "This package provides an interface for selecting from
+different conversion recipes, often including tools like @code{ffmpeg} or
+@code{convert}. The conversion command need only be written once, and
+subsequent invocations can be readily customized. Several recipes are
+included by default, and more can be readily added.")
+ (license license:gpl3+))))
+
(define-public emacs-websocket
(package
(name "emacs-websocket")