summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 15:27:27 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-03 14:31:51 +0200
commitea69e2f853f8b6ffb490310920db29de829751fb (patch)
treeca9ae3b504d2c4241df0ae4ebf036a792c132192 /gnu
parent44373339584f40b7b5ee7e8f9c513278fe914e49 (diff)
downloadguix-patches-ea69e2f853f8b6ffb490310920db29de829751fb.tar
guix-patches-ea69e2f853f8b6ffb490310920db29de829751fb.tar.gz
gnu: Add r-rcpp.
* gnu/packages/statistics.scm (r-rcpp): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 51504f1473..0da3b82c8e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -266,3 +266,28 @@ see package vignette. To quote Rene Magritte, \"Ceci n'est pas un pipe.\"")
"The Munsell package contains Functions for exploring and using the
Munsell colour system.")
(license license:expat)))
+
+(define-public r-rcpp
+ (package
+ (name "r-rcpp")
+ (version "0.12.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cran/src/contrib/Rcpp_"
+ version ".tar.gz"))
+ (sha256
+ (base32 "182109z0yc1snqgd833ssl2cix6cbq83bcxmy5344b15ym820y38"))))
+ (build-system r-build-system)
+ (home-page "http://www.rcpp.org")
+ (synopsis "Seamless R and C++ Integration")
+ (description
+ "The Rcpp package provides R functions as well as C++ classes which offer
+a seamless integration of R and C++. Many R data types and objects can be
+mapped back and forth to C++ equivalents which facilitates both writing of new
+code as well as easier integration of third-party libraries. Documentation
+about Rcpp is provided by several vignettes included in this package, via the
+'Rcpp Gallery' site at <http://gallery.rcpp.org>, the paper by Eddelbuettel
+and Francois (2011, JSS), and the book by Eddelbuettel (2013, Springer); see
+'citation(\"Rcpp\")' for details on these last two.")
+ (license license:gpl2+)))