summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-06-13 21:07:11 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-06-14 00:05:11 +0200
commita5d40ee7acd80d0472c64cd697f27045fffa4167 (patch)
tree6abbf0e9a4e9225f6b65cf5d8567a035931d14ff /gnu
parent238e2e457fdbd25798f1eb5d854d70c37e6ad1f8 (diff)
downloadguix-patches-a5d40ee7acd80d0472c64cd697f27045fffa4167.tar
guix-patches-a5d40ee7acd80d0472c64cd697f27045fffa4167.tar.gz
gnu: python-shellingham: Update to 1.3.2.
* gnu/packages/python-xyz.scm (python-shellingham): Update to 1.3.2. [arguments]: Add ‘restore-setup.py’ phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 14 insertions, 5 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index bf2e7de238..7506f7852f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11749,17 +11749,26 @@ implementation has been adapted, improved, and fixed from Molten.")
(define-public python-shellingham
(package
(name "python-shellingham")
- (version "1.3.1")
+ (version "1.3.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "shellingham" version))
(sha256
- (base32
- "1q7kws7w4x2hji3g7y0ni9ddk4sd676ylrb3db54gbpys6xj6nwq"))))
+ (base32 "07kmia2hvd2q7wik89m82hig9mqr2faynvy38vxq5fm0ps11jv2p"))))
(build-system python-build-system)
- (home-page
- "https://github.com/sarugaku/shellingham")
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'restore-setup.py
+ ;; setup.py will return in the next release.
+ ;; <https://github.com/sarugaku/shellingham/issues/33>
+ (lambda _
+ (with-output-to-file "setup.py"
+ (lambda _
+ (display "from setuptools import setup\nsetup()\n")))
+ #t)))))
+ (home-page "https://github.com/sarugaku/shellingham")
(synopsis "Tool to detect surrounding shell")
(description
"Shellingham detects what shell the current Python executable is