summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-08-06 16:52:49 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-03-07 13:43:17 +0100
commit9f3c6c8825e2935766ac5bc1880ed74f7fce48f4 (patch)
tree159bcb8a646c76332915b6ea280a0d1605673561 /gnu
parenta286b5ebdaf833a26317ba4f9a7ca76ea3b6ac74 (diff)
downloadguix-patches-9f3c6c8825e2935766ac5bc1880ed74f7fce48f4.tar
guix-patches-9f3c6c8825e2935766ac5bc1880ed74f7fce48f4.tar.gz
gnu: gnome-todo: Update to 3.28.1.
* gnu/packages/gnome.scm (gnome-todo): Update to 3.28.1. * gnu/local.mk (dist_patch_DATA): Remove patch. * gnu/packages/patches/gnome-todo-libical-compat.patch: Remove file.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnome.scm5
-rw-r--r--gnu/packages/patches/gnome-todo-libical-compat.patch17
3 files changed, 2 insertions, 21 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 45fa7d2007..38fee9e4ea 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -838,7 +838,6 @@ dist_patch_DATA = \
%D%/packages/patches/gmp-arm-asm-nothumb.patch \
%D%/packages/patches/gmp-faulty-test.patch \
%D%/packages/patches/gnome-shell-theme.patch \
- %D%/packages/patches/gnome-todo-libical-compat.patch \
%D%/packages/patches/gnome-tweak-tool-search-paths.patch \
%D%/packages/patches/gnucash-fix-test-transaction-failure.patch \
%D%/packages/patches/gnutls-skip-trust-store-test.patch \
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 6f84d60928..098b039605 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -6440,16 +6440,15 @@ desktop. It supports multiple calendars, month, week and year view.")
(define-public gnome-todo
(package
(name "gnome-todo")
- (version "3.26.2")
+ (version "3.28.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnome/sources/" name "/"
(version-major+minor version) "/"
name "-" version ".tar.xz"))
- (patches (search-patches "gnome-todo-libical-compat.patch"))
(sha256
(base32
- "106xx1w18pxjmj5k0k2qjzi6b3c3kaz7b5kyrpknykibnr401ff9"))))
+ "08ygqbib72jlf9y0a16k54zz51sncpq2wa18wp81v46q8301ymy7"))))
(build-system meson-build-system)
(arguments
'(#:glib-or-gtk? #t
diff --git a/gnu/packages/patches/gnome-todo-libical-compat.patch b/gnu/packages/patches/gnome-todo-libical-compat.patch
deleted file mode 100644
index 34f2e254b2..0000000000
--- a/gnu/packages/patches/gnome-todo-libical-compat.patch
+++ /dev/null
@@ -1,17 +0,0 @@
-Fix compatibility with libical 3.0.
-
-Patch copied from Arch Linux:
-https://git.archlinux.org/svntogit/packages.git/tree/trunk/gnome-todo-3.26.2-libical-3.0.patch?h=packages/gnome-todo
-
-diff -up gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 gnome-todo-3.26.2/src/gtd-task.c
---- gnome-todo-3.26.2/src/gtd-task.c.libical-3.0 2017-11-08 14:53:53.484294926 +0100
-+++ gnome-todo-3.26.2/src/gtd-task.c 2017-11-08 14:53:57.208294874 +0100
-@@ -778,7 +778,7 @@ gtd_task_set_complete (GtdTask *task,
- dt->minute = g_date_time_get_minute (now);
- dt->second = g_date_time_get_seconds (now);
- dt->is_date = 0;
-- dt->is_utc = 1;
-+ dt->zone = icaltimezone_get_utc_timezone ();
-
- /* convert timezone
- *