summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-10 15:09:38 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-11 15:48:05 -0500
commit9bc8671846c5a3f8567f83ff86df31df5badbd09 (patch)
treee9257055097f38098214fcc85529776f7b681a8f /gnu
parent1e507297e975aac7e7c8e507d37af330d94b0e63 (diff)
downloadguix-patches-9bc8671846c5a3f8567f83ff86df31df5badbd09.tar
guix-patches-9bc8671846c5a3f8567f83ff86df31df5badbd09.tar.gz
gnu: Add Test-MockTime.
* gnu/packages/perl.scm (perl-test-mocktime): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 4fe5f1f938..f1894196c5 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -1881,6 +1881,28 @@ testing exception-throwing code with about the same amount of typing.")
automatically aggregated and output to STDOUT.")
(license (package-license perl))))
+(define-public perl-test-mocktime
+ (package
+ (name "perl-test-mocktime")
+ (version "0.13")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://cpan/authors/id/D/DD/DDICK/"
+ "Test-MockTime-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0yrqmjg33akannwz2f99rfm7dvvxpzsdj23lsvlvfi4qslrlqfvw"))))
+ (build-system perl-build-system)
+ (home-page "http://search.cpan.org/dist/Test-MockTime")
+ (synopsis "Replaces actual time with simulated time")
+ (description "This module was created to enable test suites to test code
+at specific points in time. Specifically it overrides localtime, gmtime and
+time at compile time and then relies on the user supplying a mock time via
+set_relative_time, set_absolute_time or set_fixed_time to alter future calls
+to gmtime,time or localtime.")
+ (license (package-license perl))))
+
(define-public perl-test-most
(package
(name "perl-test-most")