summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-13 10:32:47 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-13 10:34:50 +0200
commit9a4efac9efe1f257a0f905ff8b99c90b002d1a29 (patch)
treeace9802599fa287ac512f8a5a85a1d793b0ba6e4 /gnu
parentb0e652d836fe14bc229194d9b214e4d6340a25c3 (diff)
downloadguix-patches-9a4efac9efe1f257a0f905ff8b99c90b002d1a29.tar
guix-patches-9a4efac9efe1f257a0f905ff8b99c90b002d1a29.tar.gz
gnu: fuse: Install udev rules in lib/udev/rules.d.
* gnu/packages/linux.scm (fuse): Change UDEV_RULES_PATH suffix to /lib/udev/rules.d.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm4
1 files changed, 3 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index bbfc1f6b0d..70c4cb5c61 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1009,9 +1009,11 @@ processes currently causing I/O.")
(string-append "INIT_D_PATH="
(assoc-ref %outputs "out")
"/etc/init.d")
+
+ ;; The rule makes /dev/fuse 666.
(string-append "UDEV_RULES_PATH="
(assoc-ref %outputs "out")
- "/etc/udev"))
+ "/lib/udev/rules.d"))
#:phases (alist-cons-before
'build 'set-file-names
(lambda* (#:key inputs #:allow-other-keys)