summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-09-12 22:12:33 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-12 22:13:52 +0200
commit7fa715e783af36dc98e3f53aa7ebf3d91076d779 (patch)
tree048ef86db54be7c3769330cb1a5b8b9b2903ce0f /gnu
parentc9a8ad847712dfa4811608efae2d48cb8500f72f (diff)
downloadguix-patches-7fa715e783af36dc98e3f53aa7ebf3d91076d779.tar
guix-patches-7fa715e783af36dc98e3f53aa7ebf3d91076d779.tar.gz
gnu: Add eudev.
* gnu/packages/linux.scm (eudev): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm16
1 files changed, 16 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 756b342b2f..b76d1897ab 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1326,6 +1326,7 @@ from the module-init-tools project.")
(license gpl2+))) ; library under lgpl2.1+
(define-public udev
+ ;; The last pre-systemd version.
(package
(name "udev")
(version "182")
@@ -1370,6 +1371,21 @@ device nodes from /dev/, handles hotplug events and loads drivers at boot
time.")
(license gpl2+))) ; libudev is under lgpl2.1+
+(define-public eudev
+ ;; The post-systemd fork, maintained by Gentoo.
+ (package (inherit udev)
+ (name "eudev")
+ (version "1.9")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://dev.gentoo.org/~blueness/eudev/eudev-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1w6f8h7fhjz3prs630f8gawv7jx74zi600z0pm997kkp24pyj5wg"))))
+ (home-page "http://www.gentoo.org/proj/en/eudev/")))
+
(define-public lvm2
(package
(name "lvm2")