summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorjgart via Guix-patches via <guix-patches@gnu.org>2021-11-28 10:08:55 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-12-01 17:13:27 +0100
commit7907ddbc3af325c16ea40877d7e15aef00325a0d (patch)
treec1aac2fe5bd8bc4cf424eada847a2e03578320da /gnu
parent0c3acb247a73e53ffd3752657bfca27e84920020 (diff)
downloadguix-patches-7907ddbc3af325c16ea40877d7e15aef00325a0d.tar
guix-patches-7907ddbc3af325c16ea40877d7e15aef00325a0d.tar.gz
gnu: Add python-lsp-server.
* gnu/packages/python-xyz.scm (python-language-server): Delete variable. * gnu/packages/python-xyz.scm (python-lsp-server): New variable. Removes deprecated python-language-server package and adds maintained fork. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 11 insertions, 17 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 96fdd15fba..afd875212c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -5017,29 +5017,23 @@ errors when data is invalid.")
Server (PLS).")
(license license:expat)))
-(define-public python-language-server
+(define-public python-lsp-server
(package
- (name "python-language-server")
- (version "0.36.2")
+ (name "python-lsp-server")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
- (uri (pypi-uri "python-language-server" version))
+ (uri (pypi-uri "python-lsp-server" version))
(sha256
(base32
- "1c0pnk2aibfhfaanrs0a5gkabkvz81gj20z7r0152b7fcx5ci14r"))))
+ "15075a5irjxh55wcdf25hllz9c42byxc4770cmwgb480k1dm8scq"))))
(build-system python-build-system)
(arguments
`(#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'relax-deps
- (lambda _
- (substitute* "setup.py" (("pycodestyle>=2.6.0,<2.7.0")
- "pycodestyle"))
- (substitute* "setup.py" (("pyflakes>=2.2.0,<2.3.0") "pyflakes"))
- #t))
(add-before 'check 'set-HOME
- (lambda _ (setenv "HOME" "/tmp") #t))
+ (lambda _ (setenv "HOME" "/tmp")))
(replace 'check
(lambda _
;; Disable failing test.
@@ -5052,7 +5046,7 @@ Server (PLS).")
("python-flake8" ,python-flake8)
("python-future" ,python-future)
("python-jedi" ,python-jedi)
- ("python-jsonrpc-server" ,python-jsonrpc-server)
+ ("python-lsp-jsonrpc" ,python-lsp-jsonrpc)
("python-pluggy" ,python-pluggy)
("python-pycodestyle" ,python-pycodestyle)
("python-pyflakes" ,python-pyflakes)
@@ -5073,10 +5067,10 @@ Server (PLS).")
(home-page "https://github.com/palantir/python-language-server")
(synopsis "Python implementation of the Language Server Protocol")
(description
- "The Python Language Server (pyls) is an implementation of the Python 3
-language specification for the Language Server Protocol (LSP). This tool is
-used in text editing environments to provide a complete and integrated
-feature-set for programming Python effectively.")
+"The Python Language Server @command{pylsp} is an implementation of the
+Python 3 language specification for the Language Server Protocol (LSP).
+This tool is used in text editing environments to provide a complete
+and integrated feature-set for programming Python effectively.")
(license license:expat)))
(define-public python-pathspec