summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAlexandros Theodotou <alex@zrythm.org>2020-09-10 17:50:27 +0100
committerEfraim Flashner <efraim@flashner.co.il>2020-09-11 14:14:12 +0300
commit76c18f880c3ee9bde9540e44440f5a2e1dfd4180 (patch)
tree4980b784b3558a8f9710550324b8f80030df468c /gnu
parent477311146ee42d3e2c51a84401da25c261ebb8d9 (diff)
downloadguix-patches-76c18f880c3ee9bde9540e44440f5a2e1dfd4180.tar
guix-patches-76c18f880c3ee9bde9540e44440f5a2e1dfd4180.tar.gz
gnu: geonkick: Update to 2.3.7.
* gnu/packages/music.scm (geonkick): Update to 2.3.7. [native-inputs]: Add gcc-9. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/music.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/music.scm b/gnu/packages/music.scm
index d3b180aa22..a71a20771f 100644
--- a/gnu/packages/music.scm
+++ b/gnu/packages/music.scm
@@ -5250,7 +5250,7 @@ ZaMultiComp, ZaMultiCompX2 and ZamSynth.")
(define-public geonkick
(package
(name "geonkick")
- (version "1.10.0")
+ (version "2.3.7")
(source
(origin
(method git-fetch)
@@ -5260,7 +5260,7 @@ ZaMultiComp, ZaMultiCompX2 and ZamSynth.")
(file-name (git-file-name name version))
(sha256
(base32
- "1a59wnm4035kjhs66hihlkiv45p3ffb2yaj1awvyyi5f0lds5zvh"))))
+ "1wdcbwiyy6i5agq5lffkyilyc8mv1cc4mp9h0nybn240vb2flqc2"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ;no tests included
@@ -5279,6 +5279,8 @@ ZaMultiComp, ZaMultiCompX2 and ZamSynth.")
("rapidjson" ,rapidjson)))
(native-inputs
`(("lv2" ,lv2)
+ ;; Fails with default gcc (#include <filesystem> not found).
+ ("gcc" ,gcc-9)
("pkg-config" ,pkg-config)
("sord" ,sord)))
(synopsis "Percussion synthesizer")