summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorFelix Gruber <felgru@posteo.net>2021-10-31 21:49:27 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-01 17:51:37 +0100
commit5ff34d596db98ad168f606dac6a6330faa7a52e8 (patch)
treeb1bcf7578b5f4c28700e3fa5a822d4d167f9656e /gnu
parenta82e9f45fd9f7c67123b7064c60065281035c744 (diff)
downloadguix-patches-5ff34d596db98ad168f606dac6a6330faa7a52e8.tar
guix-patches-5ff34d596db98ad168f606dac6a6330faa7a52e8.tar.gz
gnu: Add python-codespell.
* gnu/packages/python-xyz.scm (python-codespell): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f4396f174..0de304e100 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -14476,6 +14476,53 @@ checking library.")
,python2-backport-ssl-match-hostname)
,@(package-propagated-inputs whoosh))))))
+(define-public python-codespell
+ (package
+ (name "python-codespell")
+ (version "2.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "codespell" version))
+ (sha256
+ (base32 "1r9y714cz8m894rxp7pyvicr1lw2iid24vz6fxbl5wzy8ibgxlqr"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-chardet" ,python-chardet)))
+ (native-inputs
+ `(("python-check-manifest" ,python-check-manifest)
+ ("python-flake8" ,python-flake8)
+ ("python-pytest" ,python-pytest)
+ ("python-pytest-cov" ,python-pytest-cov)
+ ("python-pytest-dependency" ,python-pytest-dependency)))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key outputs tests? #:allow-other-keys)
+ (when tests?
+ ;; Make installed executable available for running the tests.
+ (setenv "PATH"
+ (string-append (assoc-ref outputs "out") "/bin"
+ ":" (getenv "PATH")))
+ (invoke "pytest" "-vv")))))))
+ (home-page "https://github.com/codespell-project/codespell/")
+ (synopsis "Spellchecker for code")
+ (description "Codespell fixes common misspellings in text files.
+It's designed primarily for checking misspelled words in source code,
+but it can be used with other files as well. It does not check for word
+membership in a complete dictionary, but instead looks for a set of
+common misspellings. Therefore it should catch errors like \"adn\", but
+it will not catch \"adnasdfasdf\". This also means it shouldn't
+generate false-positives when you use a niche term it doesn't know
+about.")
+ (license
+ (list
+ ; for codespell and codespell_lib
+ license:gpl2
+ ; for dictionary*.txt
+ license:cc-by-sa3.0))))
+
(define-public python-pathlib
(package
(name "python-pathlib")