summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAntoine Côté <antoine.cote@posteo.net>2020-06-29 11:05:18 -0400
committerRicardo Wurmus <rekado@elephly.net>2020-09-11 10:51:44 +0200
commit5412b14ba6020df267e096727af9b01393b2ee33 (patch)
tree4b2652248b44b3f7deead15ca5afbbdeaf4b3f75 /gnu
parent0fb974be9c3e1e22a2145c9c602c44cd10cef2b0 (diff)
downloadguix-patches-5412b14ba6020df267e096727af9b01393b2ee33.tar
guix-patches-5412b14ba6020df267e096727af9b01393b2ee33.tar.gz
gnu: Add r-transphylo.
* gnu/packages/cran.scm (r-transphylo): New variable. Signed-off-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8b80916c94..5cf5b0e639 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -26,6 +26,7 @@
;;; Copyright © 2020 Rafael Luque Leiva <rafael.luque@osoco.es>
;;; Copyright © 2020 Lars-Dominik Braun <ldb@leibniz-psychology.org>
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
+;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23368,3 +23369,30 @@ at least an R function defining the probability density or hazard. There are
also tools for fitting and predicting from fully parametric multi-state
models.")
(license license:gpl2+)))
+
+(define-public r-transphylo
+ (package
+ (name "r-transphylo")
+ (version "1.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "TransPhylo" version))
+ (sha256
+ (base32
+ "1506c97y8dnhd0c38rgvmg70q0l3xmmn07mjglhnw7hi5n5y9mv9"))))
+ (properties `((upstream-name . "TransPhylo")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-ape" ,r-ape)
+ ("r-rcpp" ,r-rcpp)))
+ (native-inputs
+ `(("r-knitr" ,r-knitr)))
+ (home-page "https://cran.r-project.org/web/packages/TransPhylo/")
+ (synopsis "Inference of transmission tree from a dated phylogeny")
+ (description
+ "This is a package to infer transmission trees from a dated phylogeny.
+It includes methods to simulate and analyze outbreaks. The methodology is
+described in @url{https://doi.org/10.1093/molbev/msu121,Didelot et al. (2014)}
+and @url{https://doi.org/10.1093/molbev/msw275,Didelot et al. (2017)}.")
+ (license license:gpl2+)))