summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-07-02 11:42:17 +0200
committerLudovic Courtès <ludo@gnu.org>2014-07-02 11:42:17 +0200
commit44add1ce19473990654b399c2a83707b3b76034b (patch)
treed717070be5aa0d1dfeba82ed85cc606899b6632a /gnu
parent426adbe82731b8b4968cad8d474545d3e8b55c65 (diff)
downloadguix-patches-44add1ce19473990654b399c2a83707b3b76034b.tar
guix-patches-44add1ce19473990654b399c2a83707b3b76034b.tar.gz
gnu: Adjust more packages to GLib "bin" split.
* gnu/packages/glib.scm (dbus-glib): Add glib-bin to 'native-inputs'. (glibmm): Likewise. * gnu/packages/gstreamer.scm (gstreamer-0.10): Likewise. * gnu/packages/gtk.scm (gtksourceview): Likewise. * gnu/packages/qemu.scm (qemu-headless): Likewise. * gnu/packages/gnome.scm (librsvg, libbonobo, libgnomecanvas, libgnomeprint): Likewise.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/glib.scm7
-rw-r--r--gnu/packages/gnome.scm8
-rw-r--r--gnu/packages/gstreamer.scm3
-rw-r--r--gnu/packages/gtk.scm3
-rw-r--r--gnu/packages/qemu.scm1
5 files changed, 16 insertions, 6 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index ce0d3f821d..59efc6eaf5 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -321,7 +321,9 @@ translated.")
(inputs
`(("dbus" ,dbus)
("expat" ,expat)
- ("glib" ,glib)
+ ("glib" ,glib)))
+ (native-inputs
+ `(("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page "http://dbus.freedesktop.org/doc/dbus-glib/")
(synopsis "D-Bus GLib bindings")
@@ -385,7 +387,8 @@ has an ease of use unmatched by other C++ callback libraries.")
(("Gio::init.*$")
"return 77;\n")))
%standard-phases)))
- (inputs `(("pkg-config" ,pkg-config)))
+ (inputs `(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")))
(propagated-inputs
`(("libsigc++" ,libsigc++)
("glib" ,glib)))
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index dd407c5eeb..fa96ab1763 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -598,6 +598,7 @@ dealing with different structured file formats.")
%standard-phases)))
(native-inputs
`(("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin") ; glib-mkenums, etc.
("gobject-introspection" ,gobject-introspection))) ; g-ir-compiler, etc.
(inputs
`(("pango" ,pango)
@@ -713,12 +714,13 @@ featuring mature C, C++ and Python bindings.")
(inputs `(("popt" ,popt)
("libxml2" ,libxml2)))
;; The following are Required by the .pc file
- (propagated-inputs
+ (propagated-inputs
`(("glib" ,glib)
("orbit2" ,orbit2)))
(native-inputs
`(("intltool" ,intltool)
("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
("flex" ,flex)
("bison" ,bison)))
(home-page "https://developer.gnome.org/libbonobo/")
@@ -922,6 +924,7 @@ high-quality vector-based 2D library with antialiasing and alpha composition.")
("gtk+" ,gtk+-2)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page "https://developer.gnome.org/libgnomecanvas/")
(synopsis "Flexible widget for creating interactive structured graphics")
@@ -1007,9 +1010,10 @@ widgets built in the loading process.")
`(("popt" ,popt)
("libart-lgpl" ,libart-lgpl)
("gtk+" ,gtk+-2)
- ("libxml2" ,libxml2)))
+ ("libxml2" ,libxml2)))
(native-inputs
`(("intltool" ,intltool)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(home-page "https://projects.gnome.org/gnome-print/home/faq.html")
(synopsis "printing framework for GNOME")
diff --git a/gnu/packages/gstreamer.scm b/gnu/packages/gstreamer.scm
index 6f6494d4d4..a7ad2c76ba 100644
--- a/gnu/packages/gstreamer.scm
+++ b/gnu/packages/gstreamer.scm
@@ -61,7 +61,7 @@
"GStreamer is a library for constructing graphs of media-handling
components. The applications it supports range from simple Ogg/Vorbis
playback, audio/video streaming to complex audio (mixing) and video
-(non-linear editing) processing.
+ (non-linear editing) processing.
Applications can take advantage of advances in codec and filter technology
transparently. Developers can add new codecs and filters by writing a
@@ -92,6 +92,7 @@ This package provides the core library and elements.")
("flex" ,flex)
("perl" ,perl)
("pkg-config" ,pkg-config)
+ ("glib" ,glib "bin")
("python" ,python-2)))))
(define-public gst-plugins-base
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 36fea70838..db2e849deb 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -217,7 +217,8 @@ functions which were removed.")
("xorg-server" ,xorg-server)
("shared-mime-info" ,shared-mime-info)))
(native-inputs
- `(("intltool" ,intltool)
+ `(("intltool" ,intltool)
+ ("glib" ,glib "bin")
("pkg-config" ,pkg-config)))
(arguments
`(#:phases
diff --git a/gnu/packages/qemu.scm b/gnu/packages/qemu.scm
index e396127fe3..33d23572bd 100644
--- a/gnu/packages/qemu.scm
+++ b/gnu/packages/qemu.scm
@@ -106,6 +106,7 @@
("attr" ,attr)))
(native-inputs `(("pkg-config" ,pkg-config)
("python" ,python-2) ; incompatible with Python 3 according to error message
+ ("glib" ,glib "bin") ; gtester, etc.
("texinfo" ,texinfo)
("perl" ,perl)))
(home-page "http://www.qemu-project.org")