summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 13:55:44 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:15 +0200
commit3f9702144129338ec7c8c37edc7520724b5bf62d (patch)
tree0242f95c54b7cf8ee7a6d280c10a3966845ef081 /gnu
parent65214c872a2c75f51e2243b5fee1ecdeebce10b3 (diff)
downloadguix-patches-3f9702144129338ec7c8c37edc7520724b5bf62d.tar
guix-patches-3f9702144129338ec7c8c37edc7520724b5bf62d.tar.gz
gnu: Add java-eclipse-equinox-preferences.
* gnu/packages/java.scm (java-eclipse-equinox-preferences): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 8a7af2d496..8ff24f8652 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2500,6 +2500,33 @@ registry.")
Eclipse.")
(license license:epl1.0)))
+(define-public java-eclipse-equinox-preferences
+ (package
+ (name "java-eclipse-equinox-preferences")
+ (version "3.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://repo1.maven.org/maven2/"
+ "org/eclipse/platform/org.eclipse.equinox.preferences/"
+ version "/org.eclipse.equinox.preferences-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "0k7w6c141sqym4fy3af0qkwpy4pdh2vsjpjba6rp5fxyqa24v0a2"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:tests? #f ; no tests included
+ #:jar-name "eclipse-equinox-preferences.jar"))
+ (inputs
+ `(("java-eclipse-equinox-common" ,java-eclipse-equinox-common)
+ ("java-eclipse-equinox-registry" ,java-eclipse-equinox-registry)
+ ("java-eclipse-osgi" ,java-eclipse-osgi)))
+ (home-page "http://www.eclipse.org/equinox/")
+ (synopsis "Eclipse preferences mechanism")
+ (description "This package provides the Eclipse preferences mechanism with
+the module @code{org.eclipse.equinox.preferences}.")
+ (license license:epl1.0)))
+
(define-public java-commons-cli
(package
(name "java-commons-cli")