summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-19 15:45:59 -0500
committerMark H Weaver <mhw@netris.org>2014-12-19 23:28:15 -0500
commit232af79efb065951a224b9d7751d08d6c8f4fe37 (patch)
treea34398d88011016e3fcb57e8705f4b8ff80a7329 /gnu
parent2c0a2d7a4f0ff6714c87fe04ef7b0cbf3e27a902 (diff)
downloadguix-patches-232af79efb065951a224b9d7751d08d6c8f4fe37.tar
guix-patches-232af79efb065951a224b9d7751d08d6c8f4fe37.tar.gz
gnu: Resurrect xf86-video-geode and update to 2.11.16.
* gnu/packages/patches/xf86-video-geode-glibc-2.20.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/xorg.scm (xf86-video-geode): Uncomment it. Update to 2.11.16. Add patch.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/xf86-video-geode-glibc-2.20.patch15
-rw-r--r--gnu/packages/xorg.scm44
2 files changed, 37 insertions, 22 deletions
diff --git a/gnu/packages/patches/xf86-video-geode-glibc-2.20.patch b/gnu/packages/patches/xf86-video-geode-glibc-2.20.patch
new file mode 100644
index 0000000000..4dc69e3611
--- /dev/null
+++ b/gnu/packages/patches/xf86-video-geode-glibc-2.20.patch
@@ -0,0 +1,15 @@
+Allow builds with glibc 2.20.
+Based on a patch by Peter Hutterer <peter.hutterer@who-t.net>.
+See <https://raw.githubusercontent.com/openembedded/oe-core/master/meta/recipes-graphics/xorg-driver/xf86-input-synaptics/always_include_xorg_server.h.patch>.
+
+--- xf86-video-geode-2.11.16/src/lx_memory.c.~1~ 2014-07-16 16:59:37.000000000 -0400
++++ xf86-video-geode-2.11.16/src/lx_memory.c 2014-12-19 00:38:11.753388268 -0500
+@@ -23,6 +23,8 @@
+ * software without specific prior written permission.
+ */
+
++#include <xorg-server.h>
++
+ #include "xf86.h"
+ #include "geode.h"
+ #include "cim/cim_regs.h"
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b1aa805d6e..0bbd2ddd2b 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -2480,28 +2480,28 @@ devices, thus making direct access unnecessary.")
(license license:x11)))
-;; Compilation errors: Assembler messages operand size mismatch etc.
-;; (define-public xf86-video-geode
-;; (package
-;; (name "xf86-video-geode")
-;; (version "2.11.13")
-;; (source
-;; (origin
-;; (method url-fetch)
-;; (uri (string-append
-;; "mirror://xorg/X11R7.7/src/everything/xf86-video-geode-"
-;; version
-;; ".tar.bz2"))
-;; (sha256
-;; (base32
-;; "09p2cjd2fb7h32k9qs4wp7qvhfn2zv454spv5mfplv7w2jis4863"))))
-;; (build-system gnu-build-system)
-;; (inputs `(("pkg-config" ,pkg-config)
-;; ("xorg-server" ,xorg-server)))
-;; (home-page "http://www.x.org/wiki/")
-;; (synopsis "Xorg implementation of the X Window System")
-;; (description "X.org provides an implementation of the X Window System")
-;; (license license:x11)))
+(define-public xf86-video-geode
+ (package
+ (name "xf86-video-geode")
+ (version "2.11.16")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://xorg/individual/driver/xf86-video-geode-"
+ version
+ ".tar.bz2"))
+ (sha256
+ (base32
+ "19y13xl7yfrgyis92rmxi0ld95ajgr5il0n9j1dridwzw9aizz1q"))
+ (patches (list (search-patch "xf86-video-geode-glibc-2.20.patch")))))
+ (build-system gnu-build-system)
+ (inputs `(("pkg-config" ,pkg-config)
+ ("xorg-server" ,xorg-server)))
+ (home-page "http://www.x.org/wiki/")
+ (synopsis "Xorg implementation of the X Window System")
+ (description "X.org provides an implementation of the X Window System")
+ (license license:x11)))
;; Driver for obsolete graphics cards, depends on libglide: