summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-10-04 16:01:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2021-10-12 08:40:38 +0300
commit03f6a44cfc46cd49886d7a7ec6429cc22dd97c9c (patch)
treee8bde6584d0191baedddbdd3754a45dfd1c314f4 /gnu
parent50026532a0392ff812cbc7d1c3ef888567b477ed (diff)
downloadguix-patches-03f6a44cfc46cd49886d7a7ec6429cc22dd97c9c.tar
guix-patches-03f6a44cfc46cd49886d7a7ec6429cc22dd97c9c.tar.gz
gnu: Add julia-structarrays.
* gnu/packages/julia-xyz.scm (julia-structarrays): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/julia-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index c94d29fc8e..c1ebc0fba1 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -4276,6 +4276,40 @@ are defined for @code{AbstractStrings}, and any iterator that define
applied to any distance.")
(license license:expat)))
+(define-public julia-structarrays
+ (package
+ (name "julia-structarrays")
+ (version "0.6.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/JuliaArrays/StructArrays.jl")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rjcpyjwzg70n87q5r9c5i1qzigavncslxssm3rk5a3y549py56v"))))
+ (build-system julia-build-system)
+ (propagated-inputs
+ `(("julia-dataapi" ,julia-dataapi)
+ ("julia-staticarrays" ,julia-staticarrays)
+ ("julia-tables" ,julia-tables)))
+ (native-inputs
+ `(("julia-documenter" ,julia-documenter)
+ ("julia-offsetarrays" ,julia-offsetarrays)
+ ("julia-pooledarrays" ,julia-pooledarrays)
+ ("julia-typedtables" ,julia-typedtables)
+ ("julia-weakrefstrings" ,julia-weakrefstrings)))
+ (home-page "https://github.com/JuliaArrays/StructArrays.jl")
+ (synopsis "Efficient implementation of struct arrays in Julia")
+ (description "This package introduces the type @code{StructArray} which is
+an @code{AbstractArray} whose elements are @code{struct} (for example
+@code{NamedTuples}, or @code{ComplexF64}, or a custom user defined
+@code{struct}). While a @code{StructArray} iterates @code{structs}, the layout
+is column based (meaning each field of the @code{struct} is stored in a separate
+@code{Array}).")
+ (license license:expat)))
+
(define-public julia-structtypes
(package
(name "julia-structtypes")