summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 22:19:42 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-30 08:55:45 +0100
commitf562c90aa8883e1edf4f2e977522293640949d68 (patch)
treea649258af31daeefd65f6b510334ce9f4e5cb960 /gnu
parent4675b3cfa3dbf13056dec550d5a72fbf4a73def7 (diff)
downloadguix-patches-f562c90aa8883e1edf4f2e977522293640949d68.tar
guix-patches-f562c90aa8883e1edf4f2e977522293640949d68.tar.gz
gnu: Add r-yaqcaffy.
* gnu/packages/bioconductor.scm (r-yaqcaffy): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index ade51157c4..42779d264c 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3826,3 +3826,25 @@ t-tests, fold changes and the like. It makes heavy use of the @code{affy}
library. It also has some basic scatter plot functions and mechanisms for
generating high resolution journal figures.")
(license license:gpl2+)))
+
+(define-public r-yaqcaffy
+ (package
+ (name "r-yaqcaffy")
+ (version "1.42.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "yaqcaffy" version))
+ (sha256
+ (base32
+ "192n1zvd54nm9q71vyb6dcr7ia6givf4bjwf6542jjig085lwhxk"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-simpleaffy" ,r-simpleaffy)))
+ (home-page "https://bioconductor.org/packages/yaqcaffy/")
+ (synopsis "Affymetrix quality control and reproducibility analysis")
+ (description
+ "This is a package that can be used for quality control of Affymetrix
+GeneChip expression data and reproducibility analysis of human whole genome
+chips with the MAQC reference datasets.")
+ (license license:artistic2.0)))