summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-09-03 04:25:56 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2021-09-03 04:32:16 +0200
commitdc198e8e3bc0b2780298e9c8ad64a8d0f8765676 (patch)
tree8903981ef4e5b68d2f7cf0eab462c7b0c2534951 /gnu
parentc60daa8e9dfa5f641ecb5f4f3a9135e27b58d2d7 (diff)
downloadguix-patches-dc198e8e3bc0b2780298e9c8ad64a8d0f8765676.tar
guix-patches-dc198e8e3bc0b2780298e9c8ad64a8d0f8765676.tar.gz
gnu: acpi-call-linux-module: Update to 1.2.2.
* gnu/packages/linux.scm (acpi-call-linux-module): Update to 1.2.2. [arguments]: Stop returning #t from phases. [home-page]: Match source.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm12
1 files changed, 5 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 5688734b20..1b56a1e315 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1138,7 +1138,7 @@ It has been modified to remove all non-free binary blobs.")
(define-public acpi-call-linux-module
(package
(name "acpi-call-linux-module")
- (version "1.2.1")
+ (version "1.2.2")
(source
(origin
(method git-fetch)
@@ -1147,7 +1147,7 @@ It has been modified to remove all non-free binary blobs.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0mr4rjbv6fj4phf038addrgv32940bphghw2v9n1z4awvw7wzkbg"))))
+ (base32 "1s7h9y3adyfhw7cjldlfmid79lrwz3vqlvziw9nwd6x5qdj4w9vp"))))
(build-system linux-module-build-system)
(arguments
`(#:tests? #f ; no tests
@@ -1159,8 +1159,7 @@ It has been modified to remove all non-free binary blobs.")
(lambda _
(substitute* (find-files "examples" ".")
(("^(#! *)/[^ ]*/" _ shebang)
- (string-append shebang "/usr/bin/env ")))
- #t))
+ (string-append shebang "/usr/bin/env ")))))
(add-after 'install 'install-documentation
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -1169,9 +1168,8 @@ It has been modified to remove all non-free binary blobs.")
(let ((target (string-append doc "/" file)))
(mkdir-p (dirname target))
(copy-recursively file target)))
- (list "README.md" "examples"))
- #t))))))
- (home-page "https://github.com/teleshoes/acpi_call")
+ (list "README.md" "examples"))))))))
+ (home-page "https://github.com/nix-community/acpi_call")
(synopsis "Linux kernel module to perform ACPI method calls")
(description
"This simple Linux kernel module allows calls from user space to any