summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 18:05:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-29 18:05:45 +0100
commitadf7d8135b6fbb96d9d263760e749a7ada21754b (patch)
treeab3f9babe93e0acf07ea66acecc196abe2326790 /gnu
parent0b91b7b969567e2f149606ab76ec34d332a52db6 (diff)
downloadguix-patches-adf7d8135b6fbb96d9d263760e749a7ada21754b.tar
guix-patches-adf7d8135b6fbb96d9d263760e749a7ada21754b.tar.gz
gnu: Add r-annotationtools.
* gnu/packages/bioconductor.scm (r-annotationtools): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 599f774042..be618d39b9 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3485,3 +3485,28 @@ the brain using an ontology, both provided by the Allen Brain Atlas project.")
different identifieres using the Biocore Data Team data-packages (e.g.
@code{org.Bt.eg.db}).")
(license license:gpl2)))
+
+(define-public r-annotationtools
+ (package
+ (name "r-annotationtools")
+ (version "1.56.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "annotationTools" version))
+ (sha256
+ (base32
+ "0hqy0mq6pkn05p2dv4pw24p697yvikhdn351adf2ynldy6f3sl9z"))))
+ (properties
+ `((upstream-name . "annotationTools")))
+ (build-system r-build-system)
+ (propagated-inputs `(("r-biobase" ,r-biobase)))
+ (home-page "https://bioconductor.org/packages/annotationTools/")
+ (synopsis "Annotate microarrays and perform gene expression analyses")
+ (description
+ "This package provides functions to annotate microarrays, find orthologs,
+and integrate heterogeneous gene expression profiles using annotation and
+other molecular biology information available as flat file database (plain
+text files).")
+ ;; Any version of the GPL.
+ (license (list license:gpl2+))))