summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-27 14:28:37 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-30 18:29:56 +0200
commitabe1890a5726e5cf1021b408bb5847b2f76f08d8 (patch)
tree5f25e32f8d976bc35a7261d8b1ccb46dff401229 /gnu
parente85b35070caa41926b52625ef0fa828d6acc8271 (diff)
downloadguix-patches-abe1890a5726e5cf1021b408bb5847b2f76f08d8.tar
guix-patches-abe1890a5726e5cf1021b408bb5847b2f76f08d8.tar.gz
gnu: Add python-svgutils.
* gnu/packages/python-xyz.scm (python-svgutils): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1d1a679133..5da58d3f2d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -24793,6 +24793,28 @@ For the most part it's transliterated from C, the major differences are:
"Jinxed is an implementation of a subset of the Python curses library.")
(license license:mpl2.0)))
+(define-public python-svgutils
+ (package
+ (name "python-svgutils")
+ (version "0.3.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "svgutils" version))
+ (sha256
+ (base32
+ "0lz0w2ajdvwd269a7ppnzawmx8px0116j0nx8xvhlihxrd28zx4y"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-lxml" ,python-lxml)))
+ (home-page "https://svgutils.readthedocs.io")
+ (synopsis "Python SVG editor")
+ (description "This is an utility package that helps with editing and
+concatenating SVG files. It is especially directed at scientists preparing
+final figures for submission to journals. So far it supports arbitrary
+placement and scaling of SVG figures and adding markers, such as labels.")
+ (license license:expat)))
+
(define-public python-blessed
(package
(name "python-blessed")