summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-15 18:05:25 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:31 +0100
commitabbb15309d7dd83bb99682e6962ff98f57f681f9 (patch)
treeff20de9b955dfb11594e241e9d2f3c81db3e62d5 /gnu
parent108fa8266cebc32cc384cacc6f687b8536a62506 (diff)
downloadguix-patches-abbb15309d7dd83bb99682e6962ff98f57f681f9.tar
guix-patches-abbb15309d7dd83bb99682e6962ff98f57f681f9.tar.gz
gnu: Add python-databricks-cli.
* gnu/packages/python-web.scm (python-databricks-cli): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm45
1 files changed, 44 insertions, 1 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 5fb4c9762c..f1629e0ddd 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2017 Christopher Baines <mail@cbaines.net>
;;; Copyright © 2016, 2017 Danny Milosavljevic <dannym+a@scratchpost.org>
;;; Copyright © 2013, 2014, 2015, 2016, 2020 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016, 2017, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2016, 2017, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2017 Roel Janssen <roel@gnu.org>
;;; Copyright © 2016, 2017, 2020 Julien Lepiller <julien@lepiller.eu>
@@ -1023,6 +1023,49 @@ another XPath engine to find the matching elements in an XML or HTML document.")
(define-public python2-cssselect
(package-with-python2 python-cssselect))
+(define-public python-databricks-cli
+ (package
+ (name "python-databricks-cli")
+ (version "0.14.0")
+ (home-page "https://github.com/databricks/databricks-cli")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0imwpfda2pxix1rx0nlqs48v58icfw065nsv53rpg0dw4bw9x2wi"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append "./build/lib:"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "tests" "-vv"
+ ;; XXX: This fails with newer Pytest
+ ;; (upstream uses Pytest 3..).
+ "-k" "not test_get_request_with_list"))))))
+ (native-inputs
+ `(;; For tests.
+ ("python-decorator" ,python-decorator)
+ ("python-mock" ,python-mock)
+ ("python-pytest" ,python-pytest)
+ ("python-requests-mock" ,python-requests-mock)))
+ (propagated-inputs
+ `(("python-click" ,python-click)
+ ("python-configparser" ,python-configparser)
+ ("python-requests" ,python-requests)
+ ("python-six" ,python-six)
+ ("python-tabulate" ,python-tabulate)))
+ (synopsis "Command line interface for Databricks")
+ (description
+ "The Databricks Command Line Interface is a tool which provides an easy
+to use interface to the Databricks platform. The CLI is built on top of the
+Databricks REST APIs.")
+ (license license:asl2.0)))
+
(define-public python-openid-cla
(package
(name "python-openid-cla")