summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-03-29 00:46:33 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2019-03-29 00:46:36 +0100
commita544817e800859cea57f070336ed307d78a3e399 (patch)
tree93bf52fd0937f5808e368abcc757d589860d6dae /gnu
parentdd0369f4268aaa96c2d747ebce807cfc15652b94 (diff)
downloadguix-patches-a544817e800859cea57f070336ed307d78a3e399.tar
guix-patches-a544817e800859cea57f070336ed307d78a3e399.tar.gz
gnu: nethack: Don't use NAME in source URI.
* gnu/packages/games.scm (nethack)[source]: Hard-code NAME, not VERSION.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index b04c3814d8..7f23711123 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -872,8 +872,9 @@ watch your CPU playing while enjoying a cup of tea!")
(source
(origin
(method url-fetch)
- (uri (string-append "https://www.nethack.org/download/"
- version "/" name "-361-src.tgz"))
+ (uri
+ (string-append "https://www.nethack.org/download/" version "/nethack-"
+ (string-join (string-split version #\.) "") "-src.tgz"))
(sha256
(base32 "1dha0ijvxhx7c9hr0452h93x81iiqsll8bc9msdnp7xdqcfbz32b"))))
(inputs