summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-12-20 11:37:32 -0500
committerLeo Famulari <leo@famulari.name>2021-12-20 13:02:03 -0500
commita34a13c9b4d0394b4114ddcd975a9c3f9ec8a5b6 (patch)
treeca59b6ef865b1f6a1aad85133e599aa9bc04d830 /gnu
parent84fe3a88179d5a6a5c619c408a4fd4fe2a779652 (diff)
downloadguix-patches-a34a13c9b4d0394b4114ddcd975a9c3f9ec8a5b6.tar
guix-patches-a34a13c9b4d0394b4114ddcd975a9c3f9ec8a5b6.tar.gz
gnu: Apache httpd: Update to 2.4.52 [fixes CVE-2021-{44224,44790}].
* gnu/packages/web.scm (httpd): Update to 2.4.52.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/web.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index c8d08b3fe6..1c8e4a64a1 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -254,14 +254,14 @@
(define-public httpd
(package
(name "httpd")
- (version "2.4.51")
+ (version "2.4.52")
(source (origin
(method url-fetch)
(uri (string-append "mirror://apache/httpd/httpd-"
version ".tar.bz2"))
(sha256
(base32
- "1x1qp10pfh33x1b56liwsjl0jamjm5lkk7j3lj87c1ygzs0ivq10"))))
+ "1jgmfbazc2n9dnl7axhahwppyq25bvbvwx0lqplq76by97fgf9q1"))))
(build-system gnu-build-system)
(native-inputs (list `(,pcre "bin"))) ;for 'pcre-config'
(inputs (list apr apr-util openssl perl)) ; needed to run bin/apxs