summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-16 15:10:02 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:31 +0100
commit9d3449f77accfb024db5c1f9b6abe7cc70c2ab1c (patch)
tree874c3cf81c78344c01a32041449738c03aa2e126 /gnu
parent65579957d524804ea27dec2bed4382aa00a607e2 (diff)
downloadguix-patches-9d3449f77accfb024db5c1f9b6abe7cc70c2ab1c.tar
guix-patches-9d3449f77accfb024db5c1f9b6abe7cc70c2ab1c.tar.gz
gnu: Add python-sshpubkeys.
* gnu/packages/python-xyz.scm (python-sshpubkeys): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6605cde6b4..f85aac1900 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3923,6 +3923,30 @@ augment the changelog, but it can be used for other documents, too.")
(define-public python2-rst.linker
(package-with-python2 python-rst.linker))
+(define-public python-sshpubkeys
+ (package
+ (name "python-sshpubkeys")
+ (version "3.1.0")
+ (home-page "https://github.com/ojarva/python-sshpubkeys")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url home-page)
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1h4gwmcfn84kkqh83km1vfz8sc5kr2g4gzgzmr8gz704jmqiv7nq"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-cryptography" ,python-cryptography)
+ ("python-ecdsa" ,python-ecdsa)))
+ (synopsis "OpenSSH public key parser")
+ (description
+ "This package provides a library for parsing and validating OpenSSH
+public key files.")
+ (license license:bsd-3)))
+
(define-public python-feedgenerator
(package
(name "python-feedgenerator")