summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-29 22:30:47 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-30 08:55:45 +0100
commit98a2af31a8066eff780a71a6366749cad5d3d580 (patch)
tree943d49afa6601a22bc963bfb1b05e7ce415758b7 /gnu
parent59cf26292f8aa13c4a98687371a2dafa63ccc932 (diff)
downloadguix-patches-98a2af31a8066eff780a71a6366749cad5d3d580.tar
guix-patches-98a2af31a8066eff780a71a6366749cad5d3d580.tar.gz
gnu: Add r-yarn.
* gnu/packages/bioconductor.scm (r-yarn): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 6b11b47eae..b0c1fb08bf 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -3879,3 +3879,38 @@ Tumor / Normal status) must also be provided because the test assesses if
there are global differences in the distributions between the user-defined
groups.")
(license license:gpl3+)))
+
+(define-public r-yarn
+ (package
+ (name "r-yarn")
+ (version "1.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "yarn" version))
+ (sha256
+ (base32
+ "0c84x1zq34hadpsyaa873r8kg0jcxp09c2z63377hlmhsll90l7s"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-biomart" ,r-biomart)
+ ("r-downloader" ,r-downloader)
+ ("r-edger" ,r-edger)
+ ("r-gplots" ,r-gplots)
+ ("r-limma" ,r-limma)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-preprocesscore" ,r-preprocesscore)
+ ("r-quantro" ,r-quantro)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)
+ ("r-readr" ,r-readr)))
+ (home-page "https://bioconductor.org/packages/yarn/")
+ (synopsis "Robust multi-condition RNA-Seq preprocessing and normalization")
+ (description
+ "Expedite large RNA-Seq analyses using a combination of previously
+developed tools. YARN is meant to make it easier for the user in performing
+basic mis-annotation quality control, filtering, and condition-aware
+normalization. YARN leverages many Bioconductor tools and statistical
+techniques to account for the large heterogeneity and sparsity found in very
+large RNA-seq experiments.")
+ (license license:artistic2.0)))