summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-15 19:04:15 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:31 +0100
commit48d8176e006a6e7460b81c2386119181cf360ca5 (patch)
tree63315a9cf67df89ee2c293a285e8f9e0e4e738b9 /gnu
parent0e4f87cbbab1fee2d8f7342f64ac02739ac8107e (diff)
downloadguix-patches-48d8176e006a6e7460b81c2386119181cf360ca5.tar
guix-patches-48d8176e006a6e7460b81c2386119181cf360ca5.tar.gz
gnu: Add python-minio.
* gnu/packages/python-web.scm (python-minio): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 917537b175..66e45aac8b 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -798,6 +798,41 @@ C, yielding parse times that can be a thirtieth of the html5lib parse times.")
(define-public python2-html5-parser
(package-with-python2 python-html5-parser))
+(define-public python-minio
+ (package
+ (name "python-minio")
+ (version "6.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "minio" version))
+ (sha256
+ (base32
+ "1cxpa0m7mdvpdbc1g6wlihq6ja4g4paxkl6f3q84bbnx07zpbllp"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases (modify-phases %standard-phases
+ (add-before 'check 'disable-failing-tests
+ (lambda _
+ ;; This test requires network access.
+ (delete-file "tests/unit/credentials_test.py")
+ #t)))))
+ (native-inputs
+ `(("python-faker" ,python-faker)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (propagated-inputs
+ `(("python-certifi" ,python-certifi)
+ ("python-configparser" ,python-configparser)
+ ("python-dateutil" ,python-dateutil)
+ ("python-pytz" ,python-pytz)
+ ("python-urllib3" ,python-urllib3)))
+ (home-page "https://github.com/minio/minio-py")
+ (synopsis "Programmatically access Amazon S3 from Python")
+ (description
+ "This package provides a Python library for interacting with any
+Amazon S3 compatible object storage server.")
+ (license license:asl2.0)))
+
(define-public python-pycurl
(package
(name "python-pycurl")