summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-16 15:42:36 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:32 +0100
commit484459fa478da3f5cf5e4db1fd949f4070de022a (patch)
tree592e27cc96d19a905a1e1b68fc0708c489c96f83 /gnu
parent9d3449f77accfb024db5c1f9b6abe7cc70c2ab1c (diff)
downloadguix-patches-484459fa478da3f5cf5e4db1fd949f4070de022a.tar
guix-patches-484459fa478da3f5cf5e4db1fd949f4070de022a.tar.gz
gnu: Add python-jsonpickle.
* gnu/packages/python-web.scm (python-jsonpickle): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-web.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 66e45aac8b..444561a8f9 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -76,6 +76,7 @@
#:use-module (gnu packages python-check)
#:use-module (gnu packages python-compression)
#:use-module (gnu packages python-crypto)
+ #:use-module (gnu packages python-science)
#:use-module (gnu packages python-xyz)
#:use-module (gnu packages serialization)
#:use-module (gnu packages sphinx)
@@ -497,6 +498,43 @@ Swartz.")
(base32
"0ppgjplg06kmv9sj0x8p7acczcq2mcfgk1jdjwm4w5w40b0vj5pm")))))))
+(define-public python-jsonpickle
+ (package
+ (name "python-jsonpickle")
+ (version "1.4.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "jsonpickle" version))
+ (sha256
+ (base32
+ "1fn86z468hamw8njh2grw2xdhsm7g48dyxs3lw0n10nn1g6vgm78"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (setenv "PYTHONPATH"
+ (string-append "./build/lib:"
+ (getenv "PYTHONPATH")))
+ (invoke "pytest" "-vv"
+ ;; Prevent running the flake8 and black
+ ;; pytest plugins, which only tests style
+ ;; and frequently causes harmless failures.
+ "-o" "addopts=''"))))))
+ (native-inputs
+ `(("python-setuptools-scm" ,python-setuptools-scm)
+ ("python-toml" ,python-toml) ;XXX: for setuptools_scm[toml]
+ ;; For tests.
+ ("python-numpy" ,python-numpy)
+ ("python-pandas" ,python-pandas)
+ ("python-pytest" ,python-pytest)))
+ (home-page "https://jsonpickle.github.io/")
+ (synopsis "Serialize object graphs into JSON")
+ (description
+ "This package provides a Python library for serializing any arbitrary
+object graph to and from JSON.")
+ (license license:bsd-3)))
+
(define-public python-mechanicalsoup
(package
(name "python-mechanicalsoup")