summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-10-15 15:51:50 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-10-15 17:16:47 +0200
commitbe1c4b079e15a69193e0c2b4a6dd93d01934b8c6 (patch)
tree7aa46d0294f5ff586dc23db3debeaaac334975bc /gnu
parent559e06b61c66af8cfee8fdf9bc356466ad55486e (diff)
downloadguix-patches-be1c4b079e15a69193e0c2b4a6dd93d01934b8c6.tar
guix-patches-be1c4b079e15a69193e0c2b4a6dd93d01934b8c6.tar.gz
gnu: network-manager-applet: Build libnm-gtk.
Fixes network-manager-openvpn <https://issues.guix.gnu.org/issue/37759>. * gnu/packages/gnome.scm (network-manager-applet)[arguments]: Set libnm_gtk=true in #:configure-flags.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnome.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 81cb2fb37f..20c050f984 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5487,6 +5487,7 @@ services.")
(define-public network-manager-openvpn
(package
(name "network-manager-openvpn")
+ ;; Updating? Check whether network-manager-applet still needs libnm_gtk.
(version "1.8.4")
(source (origin
(method url-fetch)
@@ -5671,7 +5672,10 @@ Cisco's AnyConnect SSL VPN.")
"1gzvz4wfqfsfclqg56y954al8x6fmz71cnxlx1i4nqr7a25bp2qi"))))
(build-system meson-build-system)
(arguments
- '(#:glib-or-gtk? #t))
+ '(#:configure-flags
+ ;; ‘Nobody should be using this’ but network-manager-openvpn 1.8.10 does.
+ (list "-Dlibnm_gtk=true")
+ #:glib-or-gtk? #t))
(native-inputs
`(("intltool" ,intltool)
("glib:bin" ,glib "bin") ; for glib-compile-resources, etc.