summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-15 09:40:59 +0200
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-15 14:25:42 +0200
commitb2b23d124271c4578bfab15ebf967c46b4c6b3dd (patch)
tree76fa68b91e0beb935d463ad26d7791a79e427ba5 /gnu
parent6830120e5822a4f3bb6927613dd624ef3d565980 (diff)
downloadguix-patches-b2b23d124271c4578bfab15ebf967c46b4c6b3dd.tar
guix-patches-b2b23d124271c4578bfab15ebf967c46b4c6b3dd.tar.gz
gnu: Add python-whichcraft.
* gnu/packages/python-xyz.scm (python-whichcraft): New public variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 145de90d8e..3699a4ced5 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9127,6 +9127,27 @@ server with very acceptable performance.")
(define-public python2-waitress
(package-with-python2 python-waitress))
+(define-public python-whichcraft
+ (package
+ (name "python-whichcraft")
+ (version "0.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "whichcraft" version))
+ (sha256
+ (base32
+ "11yfkzyplizdgndy34vyd5qlmr1n5mxis3a3svxmx8fnccdvknxc"))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-pytest" ,python-pytest)))
+ (home-page "https://github.com/pydanny/whichcraft")
+ (synopsis "Cross-platform cross-python shutil.which functionality")
+ (description
+ "This package provides a shim of the shutil.which function that's
+designed to work across multiple versions of Python.")
+ (license license:bsd-3)))
+
(define-public python-pyquery
(package
(name "python-pyquery")