summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-20 21:42:48 +0100
committerTaylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>2015-02-25 15:38:17 +0100
commit9f1cdd9dfabddec447cd5d82d0d5c791601eef9d (patch)
tree06c2ff9f56a594476c4a83aba9871f5581ffc7b0 /gnu
parente6caa52d859718596fe56bcd4033917457864912 (diff)
downloadguix-patches-9f1cdd9dfabddec447cd5d82d0d5c791601eef9d.tar
guix-patches-9f1cdd9dfabddec447cd5d82d0d5c791601eef9d.tar.gz
gnu: Add libsbsms.
* gnu/packages/audio.scm (libsbsms): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/audio.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index a4c16fb00b..0e0310b720 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2015 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -26,6 +27,7 @@
#:use-module (guix build-system trivial)
#:use-module (gnu packages)
#:use-module (gnu packages algebra)
+ #:use-module (gnu packages autotools)
#:use-module (gnu packages boost)
#:use-module (gnu packages base)
#:use-module (gnu packages compression)
@@ -744,3 +746,37 @@ analysis plugins or audio feature extraction plugins.")
(license
(license:x11-style
"https://code.soundsoftware.ac.uk/projects/vamp-plugin-sdk/repository/entry/COPYING"))))
+
+(define-public libsbsms
+ (package
+ (name "libsbsms")
+ (version "2.0.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/sbsms/sbsms/" version
+ "/libsbsms-" version ".tar.gz"))
+ (sha256
+ (base32 "1vmf84iy4dkwxv887grnlsfk43fmhd9gbg26gc2kgcv40sbkvayf"))))
+ (build-system gnu-build-system)
+ (native-inputs `(("automake" ,automake)))
+ (arguments
+ `(#:phases
+ (alist-cons-after
+ 'unpack 'fix-ar-lib-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ ;; Originally a symlink to '/usr/local/share/automake-1.12/ar-lib'.
+ (delete-file "ar-lib")
+ (symlink
+ (string-append (assoc-ref inputs "automake") "/share/automake-"
+ ,(package-version automake) "/ar-lib")
+ "ar-lib"))
+ %standard-phases)))
+ (home-page "http://sbsms.sourceforge.net/")
+ (synopsis "Library for time stretching and pitch scaling of audio")
+ (description
+ "SBSMS (Subband Sinusoidal Modeling Synthesis) is software for time
+stretching and pitch scaling of audio. This package contains the library.")
+ ;; There is no explicit declaration of a license, but a COPYING file
+ ;; containing gpl2.
+ (license license:gpl2)))