summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-02 12:23:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-10 17:59:24 +0200
commit840969e8294b281e3460bd35e95a6e5bb9befeca (patch)
tree5822039a7335f4a4b85bc807c33c57392a8f628b /gnu
parenta8d3cb62abb2f9760d2144412ef557ea3b1ebfc8 (diff)
downloadguix-patches-840969e8294b281e3460bd35e95a6e5bb9befeca.tar
guix-patches-840969e8294b281e3460bd35e95a6e5bb9befeca.tar.gz
gnu: Add java-commons-math3.
* gnu/packages/java.scm (java-commons-math3): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index eae1c85616..587f85df71 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1473,3 +1473,47 @@ GNU @code{getopt_long}. It also aims to make option parser configuration and
retrieval of options and their arguments simple and expressive, without being
overly clever.")
(license license:expat)))
+
+(define-public java-commons-math3
+ (package
+ (name "java-commons-math3")
+ (version "3.6.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/commons/math/source/"
+ "commons-math3-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "19l6yp44qc5g7wg816nbn5z3zq3xxzwimvbm4a8pczgvpi4i85s6"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:build-target "jar"
+ #:test-target "test"
+ #:make-flags
+ (let ((hamcrest (assoc-ref %build-inputs "java-hamcrest-core"))
+ (junit (assoc-ref %build-inputs "java-junit")))
+ (list (string-append "-Djunit.jar=" junit "/share/java/junit.jar")
+ (string-append "-Dhamcrest.jar=" hamcrest
+ "/share/java/hamcrest-core.jar")))
+ #:phases
+ (modify-phases %standard-phases
+ ;; We want to build the jar in the build phase and run the tests
+ ;; later in a separate phase.
+ (add-after 'unpack 'untangle-targets
+ (lambda _
+ (substitute* "build.xml"
+ (("name=\"jar\" depends=\"test\"")
+ "name=\"jar\" depends=\"compile\""))
+ #t))
+ ;; There is no install target.
+ (replace 'install
+ (install-jars "target")))))
+ (native-inputs
+ `(("java-junit" ,java-junit)
+ ("java-hamcrest-core" ,java-hamcrest-core)))
+ (home-page "http://commons.apache.org/math/")
+ (synopsis "Apache Commons mathematics library")
+ (description "Commons Math is a library of lightweight, self-contained
+mathematics and statistics components addressing the most common problems not
+available in the Java programming language or Commons Lang.")
+ (license license:asl2.0)))