summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCaliph Nomble <calnomble@protonmail.com>2021-01-19 22:47:19 +0000
committerLeo Famulari <leo@famulari.name>2021-01-24 14:06:17 -0500
commit82fd2eeed3335116cac6bd198420da7ba36cbc52 (patch)
tree664443aa39549a31cd1e6c57232539b89a8907fb /gnu
parentc95f7dc6f113dc66ca463e3a44c309c0c5ccd7f4 (diff)
downloadguix-patches-82fd2eeed3335116cac6bd198420da7ba36cbc52.tar
guix-patches-82fd2eeed3335116cac6bd198420da7ba36cbc52.tar.gz
gnu: linux-libre: Allow disk encryption by default.
* gnu/packages/linux.scm (%default-extra-linux-options): Enable CONFIG_DM_CRYPT as a module. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 2 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e0f056aff9..d17ea4f43d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -641,6 +641,8 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("CONFIG_MEMCG_KMEM" . #t)
("CONFIG_CPUSETS" . #t)
("CONFIG_PROC_PID_CPUSET" . #t)
+ ;; Allow disk encryption by default
+ ("CONFIG_DM_CRYPT" . m)
;; Modules required for initrd:
("CONFIG_NET_9P" . m)
("CONFIG_NET_9P_VIRTIO" . m)