summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <leungbk@mailfence.com>2019-10-15 15:06:58 -0700
committerBrian Leung <leungbk@mailfence.com>2019-10-15 15:06:58 -0700
commit808dd2d0abb89f953c41b28a7ab209ff0b7984d3 (patch)
tree2cff8f75c89be5456e10a01ac83be1363f57512c /gnu
parent11af54466c2b001cf3aeb729197e1c3ebefab363 (diff)
downloadguix-patches-808dd2d0abb89f953c41b28a7ab209ff0b7984d3.tar
guix-patches-808dd2d0abb89f953c41b28a7ab209ff0b7984d3.tar.gz
gnu: python-language-server: Update to 0.29.1.
* gnu/packages/python-xyz.scm (python-language-server): Update to 0.29.1. [inputs]: Add python-flake8
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm63
1 files changed, 29 insertions, 34 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4ea426d0d7..57d581990a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3121,44 +3121,39 @@ Language (TOML) configuration files.")
Server (PLS).")
(license license:expat)))
-;; XXX: We must use a non-release version since the latest release version
-;; requires python-jedi version < 0.15.
(define-public python-language-server
- (let ((commit "c3cab77a85b1de4af1aec1bafea6a7320d6baec5")
- (revision "1"))
- (package
- (name "python-language-server")
- (version (git-version "0.28.3" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/palantir/python-language-server.git")
- (commit commit)))
- (sha256
- (base32
- "1q0xdwgln09sh58j0ryygj92hfgdhwcs57zjvqihya23jr5v0bz4"))))
- (build-system python-build-system)
- (propagated-inputs
- `(("python-pluggy" ,python-pluggy)
- ("python-jsonrpc-server" ,python-jsonrpc-server)
- ("python-jedi" ,python-jedi)
- ("python-yapf" ,python-yapf)
- ("python-pyflakes" ,python-pyflakes)
- ("python-pydocstyle" ,python-pydocstyle)
- ("python-pycodestyle" ,python-pycodestyle)
- ("python-mccabe" ,python-mccabe)
- ("python-rope" ,python-rope)
- ("python-autopep8" ,python-autopep8)
- ("python-pylint" ,python-pylint)))
- (home-page "https://github.com/palantir/python-language-server")
- (synopsis "Python implementation of the Language Server Protocol")
- (description
- "The Python Language Server (pyls) is an implementation of the Python 3
+ (package
+ (name "python-language-server")
+ (version "0.29.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "python-language-server" version))
+ (sha256
+ (base32
+ "1f8qlflh6j3s7qfmzhirpl8fgidl6f0qbakdmiml96wdxzvka0s3"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pluggy" ,python-pluggy)
+ ("python-jsonrpc-server" ,python-jsonrpc-server)
+ ("python-jedi" ,python-jedi)
+ ("python-yapf" ,python-yapf)
+ ("python-pyflakes" ,python-pyflakes)
+ ("python-pydocstyle" ,python-pydocstyle)
+ ("python-pycodestyle" ,python-pycodestyle)
+ ("python-mccabe" ,python-mccabe)
+ ("python-rope" ,python-rope)
+ ("python-autopep8" ,python-autopep8)
+ ("python-flake8" ,python-flake8)
+ ("python-pylint" ,python-pylint)))
+ (home-page "https://github.com/palantir/python-language-server")
+ (synopsis "Python implementation of the Language Server Protocol")
+ (description
+ "The Python Language Server (pyls) is an implementation of the Python 3
language specification for the Language Server Protocol (LSP). This tool is
used in text editing environments to provide a complete and integrated
feature-set for programming Python effectively.")
- (license license:expat))))
+ (license license:expat)))
(define-public python-black
(package