summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-09-09 16:51:08 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-10 17:59:25 +0200
commit7d91c1b9a0e36b18b8c05159dd454e9c0d7574b6 (patch)
treed7b146cd21f5d7e3d9fc7ecb72f9d8d654feda80 /gnu
parent0a8519bc11013ec15954b372cb9bf078e5700d28 (diff)
downloadguix-patches-7d91c1b9a0e36b18b8c05159dd454e9c0d7574b6.tar
guix-patches-7d91c1b9a0e36b18b8c05159dd454e9c0d7574b6.tar.gz
gnu: Add java-commons-daemon.
* gnu/packages/java.scm (java-commons-daemon): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index a69d0996e2..88d7c028d8 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1853,3 +1853,37 @@ phonetic encoding utilities.
This is a part of the Apache Commons Project.")
(license license:asl2.0)))
+
+(define-public java-commons-daemon
+ (package
+ (name "java-commons-daemon")
+ (version "1.0.15")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://apache/commons/daemon/source/"
+ "commons-daemon-" version "-src.tar.gz"))
+ (sha256
+ (base32
+ "0ci46kq8jpz084ccwq0mmkahcgsmh20ziclp2jf5i0djqv95gvhi"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:test-target "test"
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'build 'build-javadoc ant-build-javadoc)
+ (replace 'install (install-jars "dist"))
+ (add-after 'install 'install-doc (install-javadoc "dist/docs/api")))))
+ (native-inputs
+ `(("java-junit" ,java-junit)))
+ (home-page "http://commons.apache.org/daemon/")
+ (synopsis "Library to launch Java applications as daemons")
+ (description "The Daemon package from Apache Commons can be used to
+implement Java applications which can be launched as daemons. For example the
+program will be notified about a shutdown so that it can perform cleanup tasks
+before its process of execution is destroyed by the operation system.
+
+This package contains the Java library. You will also need the actual binary
+for your architecture which is provided by the jsvc package.
+
+This is a part of the Apache Commons Project.")
+ (license license:asl2.0)))