summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-07-26 00:42:05 +0200
committerLudovic Courtès <ludo@gnu.org>2016-07-26 00:43:52 +0200
commit5dbfbef7292a43029b17e89d682d9e24703d5cd2 (patch)
tree751280331be6207477389e1d7b9c907489f76647 /gnu
parent6689d09457c8d55b4f045ef9116478ffe02679df (diff)
downloadguix-patches-5dbfbef7292a43029b17e89d682d9e24703d5cd2.tar
guix-patches-5dbfbef7292a43029b17e89d682d9e24703d5cd2.tar.gz
gnu: lpsolve: Fix compilation issue.
Reported by Andreas Enge <andreas@enge.fr> at <https://lists.gnu.org/archive/html/guix-devel/2016-07/msg01018.html>. * gnu/packages/maths.scm (lpsolve)[source]: Augment 'snippet'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/maths.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 0e6fda3758..9f10933a64 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -2189,7 +2189,14 @@ specifications.")
;; Pretend to be on a 64 bit platform to obtain a common directory
;; name for the build results on all architectures; nothing else
;; seems to depend on it.
- (("^PLATFORM=.*$") "PLATFORM=ux64\n")))))
+ (("^PLATFORM=.*$") "PLATFORM=ux64\n")
+
+ ;; The check for 'isnan' as it is written fails with
+ ;; "non-floating-point argument in call to function
+ ;; ‘__builtin_isnan’", which leads to the 'NOISNAN' cpp macro
+ ;; definition, which in turn leads to bad things. Fix the feature
+ ;; test.
+ (("isnan\\(0\\)") "isnan(0.)")))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no check target