summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-16 09:31:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-16 09:31:54 +0300
commit4a822462ef66c4c61d2f3351cc2d91dd76e1a701 (patch)
treeb524e51045e779810fcdcc82a199d4aad53f3c07 /gnu
parent9eb6d7125bc122aed1faff21ac7aa4a04e55ff74 (diff)
downloadguix-patches-4a822462ef66c4c61d2f3351cc2d91dd76e1a701.tar
guix-patches-4a822462ef66c4c61d2f3351cc2d91dd76e1a701.tar.gz
Revert "gnu: aspell: Update to 0.60.8."
This reverts commit 4fcb6a3558b4212462c7c2afd2f5a834342f41be. aspell causes about 1400 packages to be rebuilt.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/aspell.scm9
-rw-r--r--gnu/packages/patches/aspell-gcc-compat.patch31
3 files changed, 37 insertions, 4 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 559655abc5..3fbfe0f2bb 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -695,6 +695,7 @@ dist_patch_DATA = \
%D%/packages/patches/antlr3-3_3-fix-java8-compilation.patch \
%D%/packages/patches/apr-skip-getservbyname-test.patch \
%D%/packages/patches/aspell-default-dict-dir.patch \
+ %D%/packages/patches/aspell-gcc-compat.patch \
%D%/packages/patches/ath9k-htc-firmware-binutils.patch \
%D%/packages/patches/ath9k-htc-firmware-gcc.patch \
%D%/packages/patches/ath9k-htc-firmware-objcopy.patch \
diff --git a/gnu/packages/aspell.scm b/gnu/packages/aspell.scm
index d3015617ec..9482e641cf 100644
--- a/gnu/packages/aspell.scm
+++ b/gnu/packages/aspell.scm
@@ -38,7 +38,7 @@
(define-public aspell
(package
(name "aspell")
- (version "0.60.8")
+ (version "0.60.6.1")
(source
(origin
(method url-fetch)
@@ -46,8 +46,9 @@
version ".tar.gz"))
(sha256
(base32
- "1wi60ankalmh8ds7nplz434jd7j94gdvbahdwsr539rlad8pxdzr"))
- (patches (search-patches "aspell-default-dict-dir.patch"))))
+ "1qgn5psfyhbrnap275xjfrzppf5a83fb67gpql0kfqv37al869gm"))
+ (patches (search-patches "aspell-default-dict-dir.patch"
+ "aspell-gcc-compat.patch"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -143,7 +144,7 @@ dictionaries, including personal ones.")
(define-public aspell-dict-ar
(aspell-dictionary "ar" "Arabic"
#:version "1.2-0"
- #:prefix "aspell6-"
+ #:prefix "aspell6-"
#:sha256
(base32
"1avw40bp8yi5bnkq64ihm2rldgw34lk89yz281q9bmndh95a47h4")))
diff --git a/gnu/packages/patches/aspell-gcc-compat.patch b/gnu/packages/patches/aspell-gcc-compat.patch
new file mode 100644
index 0000000000..94c44f8fb6
--- /dev/null
+++ b/gnu/packages/patches/aspell-gcc-compat.patch
@@ -0,0 +1,31 @@
+Fix GCC7 warnings.
+
+Taken from upstream:
+https://git.savannah.gnu.org/cgit/aspell.git/commit/?id=8089fa02122fed0a6394eba14bbedcb1d18e2384
+
+diff --git a/modules/filter/tex.cpp b/modules/filter/tex.cpp
+index a979539..19ab63c 100644
+--- a/modules/filter/tex.cpp
++++ b/modules/filter/tex.cpp
+@@ -174,7 +174,7 @@ namespace {
+
+ if (c == '{') {
+
+- if (top.in_what == Parm || top.in_what == Opt || top.do_check == '\0')
++ if (top.in_what == Parm || top.in_what == Opt || *top.do_check == '\0')
+ push_command(Parm);
+
+ top.in_what = Parm;
+diff --git a/prog/check_funs.cpp b/prog/check_funs.cpp
+index db54f3d..89ee09d 100644
+--- a/prog/check_funs.cpp
++++ b/prog/check_funs.cpp
+@@ -647,7 +647,7 @@ static void print_truncate(FILE * out, const char * word, int width) {
+ }
+ }
+ if (i == width-1) {
+- if (word == '\0')
++ if (*word == '\0')
+ put(out,' ');
+ else if (word[len] == '\0')
+ put(out, word, len);