summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-03-02 12:21:30 +0100
committerRicardo Wurmus <rekado@elephly.net>2017-05-10 17:59:23 +0200
commit33e34bfef8dea364e06965431a20ce666ad6bcae (patch)
tree259b9397638fa9fffbb849724fd54bb8e4915d29 /gnu
parent607fe24ad45e0b967373abdfad534dd3d5f2feb2 (diff)
downloadguix-patches-33e34bfef8dea364e06965431a20ce666ad6bcae.tar
guix-patches-33e34bfef8dea364e06965431a20ce666ad6bcae.tar.gz
gnu: Add java-objenesis.
* gnu/packages/java.scm (java-objenesis): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index b8b2b5e17f..6e8e1d58c0 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1339,3 +1339,32 @@ complex transformations and code analysis tools.")
(description "The byte code generation library CGLIB is a high level API
to generate and transform Java byte code.")
(license license:asl2.0)))
+
+(define-public java-objenesis
+ (package
+ (name "java-objenesis")
+ (version "2.5.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/easymock/objenesis/"
+ "archive/" version ".tar.gz"))
+ (file-name (string-append "objenesis-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1va5qz1i2wawwavhnxfzxnfgrcaflz9p1pg03irrjh4nd3rz8wh6"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "objenesis.jar"
+ #:source-dir "main/src/"
+ #:test-dir "main/src/test/"))
+ (native-inputs
+ `(("java-junit" ,java-junit)
+ ("java-hamcrest-core" ,java-hamcrest-core)))
+ (home-page "http://objenesis.org/")
+ (synopsis "Bypass the constructor when creating an object")
+ (description "Objenesis is a small Java library that serves one purpose:
+to instantiate a new object of a particular class. It is common to see
+restrictions in libraries stating that classes must require a default
+constructor. Objenesis aims to overcome these restrictions by bypassing the
+constructor on object instantiation.")
+ (license license:asl2.0)))